Opened 11 years ago

Last modified 10 years ago

#12849 closed defect

The argspecs of extension function/methods is broken in the Sphinx documentation — at Version 8

Reported by: Florent Hivert Owned by: mvngu, hivert
Priority: critical Milestone: sage-5.0
Component: documentation Keywords: argspecs Cython
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

In the current Sphinx HTML doc, the extenstion function and methods have no arguments setup.

See for example the documentation of

reference/sage/symbolic/expression.html#sage.symbolic.expression.Expression.N

which was ok (see there) in Sage 4.8. The problem was introduced in sage-5.0.beta8.

We should add a regression test on that kinds of problem: 12849_doctest.patch

Change History (9)

comment:1 Changed 11 years ago by Florent Hivert

Owner: changed from Minh Van Nguyen to mvngu, hivert

Changed 11 years ago by Jeroen Demeyer

Attachment: 12849_doctest.patch added

Doctest for the issue

comment:2 Changed 11 years ago by Jeroen Demeyer

I created a doctest for this issue, which obviously fails on recent Sage betas.

comment:3 in reply to:  2 ; Changed 11 years ago by Florent Hivert

Replying to jdemeyer:

I created a doctest for this issue, which obviously fails on recent Sage betas.

Thanks ! I tried to figureout a way to call directly Sphinx but this is much easier. I'll try to work on this this afternoon. Do you have somewhere the various beta compiled so that I can rsync them on boxen to help bissecting ? So far the few guesses I made to find the culprit were wrong.

comment:4 Changed 11 years ago by Jeroen Demeyer

sage-5.0.beta5 is still okay.

comment:5 in reply to:  3 Changed 11 years ago by Jeroen Demeyer

Replying to hivert:

Replying to jdemeyer:

I created a doctest for this issue, which obviously fails on recent Sage betas.

Thanks ! I tried to figureout a way to call directly Sphinx but this is much easier. I'll try to work on this this afternoon. Do you have somewhere the various beta compiled so that I can rsync them on boxen to help bissecting ? So far the few guesses I made to find the culprit were wrong.

Look at http://boxen.math.washington.edu/home/release/. There should be binaries for all Sage betas, made on sage.math or boxen.math.

comment:6 Changed 11 years ago by Jeroen Demeyer

Description: modified (diff)

comment:7 Changed 11 years ago by Florent Hivert

It seems that I have a fix, but I don't understand how it worked before ! Still looking.

Florent

comment:8 Changed 11 years ago by Jeroen Demeyer

Description: modified (diff)

It looks like this was introduced in sage-5.0.beta8.

Note: See TracTickets for help on using tickets.