Opened 8 years ago

Closed 5 years ago

#12822 closed enhancement (fixed)

Portuguese translation of "Tutorial"

Reported by: goliveira Owned by: mvngu
Priority: minor Milestone: sage-6.6
Component: translations Keywords: translation, portuguese
Cc: r.gaia.cs, jhpalmieri, jdemeyer Merged in:
Authors: Gustavo de Oliveira Reviewers: Paulo César Pereira de Andrade, Jeroen Demeyer, Frédéric Chapoton, Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: 9dc3771 (Commits) Commit: 9dc3771aea869eaa342c98e535bc3d7681af2230
Dependencies: Stopgaps:

Description (last modified by goliveira)

Portuguese translation of "Tutorial".

The current version of the translation includes "the first revision" and a minor modification (incorporating a suggestion above). "The first revision" originated from a discussion at sage-devel:

https://groups.google.com/d/topic/sage-devel/2fjtcJTTNr8/discussion

Everything is combined in a single patch.


Apply trac_12822_pt_translation_of_tutorial_rc1.patch

Attachments (3)

trac_12822_pt_translation_of_tutorial.patch (218.9 KB) - added by goliveira 8 years ago.
trac_12822_pt_translation_of_tutorial_rev1.patch (21.9 KB) - added by goliveira 8 years ago.
trac_12822_pt_translation_of_tutorial_rc1.patch (219.0 KB) - added by goliveira 7 years ago.

Download all attachments as: .zip

Change History (53)

Changed 8 years ago by goliveira

comment:1 Changed 8 years ago by goliveira

  • Description modified (diff)

comment:2 Changed 8 years ago by goliveira

  • Status changed from new to needs_review

comment:3 Changed 8 years ago by goliveira

  • Type changed from PLEASE CHANGE to enhancement

comment:4 Changed 8 years ago by goliveira

  • Description modified (diff)

comment:5 Changed 8 years ago by goliveira

  • Description modified (diff)

comment:6 Changed 8 years ago by pcpa

In doc/pt/tutorial/programming.rst

Removed untranslated "preparsing", should have used "pré-processamento".

I know I commented about "macro" not having a proper translation in pt_BR, but it is already so commonly used, that it should be better to use it instead of "função" (english function).

Remaining looks good, but I still make considerations about conversion and coercion, that by themselves are also confusing in english, and pt_BR makes things worse by having several translations for coercion, most of which are about forced to do something, slavering, etc :-)

It is also funny that "coercion" accordingly to sage documentation stand for "implicit conversion", but common lisp has the function "coerce" that is used for "explicit conversion".

comment:7 Changed 7 years ago by r.gaia.cs

  • Cc r.gaia.cs added

comment:8 Changed 7 years ago by r.gaia.cs

  • Description modified (diff)

I have rebase the #12502.

IMHO, it best to translate the comments of the codes, e.g., in the place of

    sage: 2**3    #  ** means exponent

should be use

    sage: 2**3    #  ** indica potenciação
Last edited 7 years ago by r.gaia.cs (previous) (diff)

comment:9 Changed 7 years ago by pcpa

I built my fedora sagemath 5.4.beta1 experimental package with procedure to copy png files and patch from #12502 and patches here, and it builds and works correctly.

comment:10 Changed 7 years ago by pcpa

  • Description modified (diff)
  • Status changed from needs_review to positive_review

comment:11 Changed 7 years ago by jdemeyer

  • Dependencies changed from 12502 to #12502
  • Description modified (diff)
  • Merged in set to Paulo César Pereira de Andrade

comment:12 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.4 to sage-5.5

comment:13 Changed 7 years ago by jdemeyer

  • Merged in Paulo César Pereira de Andrade deleted
  • Reviewers set to Paulo César Pereira de Andrade

comment:14 Changed 7 years ago by jdemeyer

  • Dependencies changed from #12502 to #12502, #9774
  • Status changed from positive_review to needs_work

Sorry for the trouble, but this needs to be rebased to #9774 and #13072 and #12290.

Last edited 7 years ago by jdemeyer (previous) (diff)

comment:15 Changed 7 years ago by jdemeyer

  • Dependencies changed from #12502, #9774 to #12502, #9774, #13072, #12290

Changed 7 years ago by goliveira

comment:16 Changed 7 years ago by goliveira

  • Dependencies changed from #12502, #9774, #13072, #12290 to sage-5.5.rc0
  • Description modified (diff)
  • Status changed from needs_work to needs_review

comment:17 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:18 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:19 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:20 Changed 5 years ago by chapoton

  • Branch set to u/chapoton/12822
  • Commit set to 3f66c432441d012c4623e13a45221e904d8a0bf8
  • Dependencies sage-5.5.rc0 deleted
  • Status changed from needs_review to needs_work

Here is a git branch. I have made sure that all tests pass.

There remains some work in the latex.rst file to replace reference to JSMath by references to MathJax?.


New commits:

d53952eTrac 12822: Portuguese translation of "Tutorial" (rc1).
3f66c43trac #12822 portuguese tutorial

comment:21 Changed 5 years ago by chapoton

  • Work issues set to newstyle of doctest continuation

comment:22 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:23 Changed 5 years ago by git

  • Commit changed from 3f66c432441d012c4623e13a45221e904d8a0bf8 to b0bebd69b21c0c0044938d6600afd860fb999abf

Branch pushed to git repo; I updated commit sha1. New commits:

0dd8362Merge branch 'u/chapoton/12822' of ssh://trac.sagemath.org:22/sage into 12822
b0bebd6trac #12822 newstyle ....: for doctest continuation

comment:24 Changed 5 years ago by kcrisman

  • Component changed from documentation to translations

comment:25 Changed 5 years ago by chapoton

  • Status changed from needs_work to needs_review
  • Work issues newstyle of doctest continuation deleted

comment:26 Changed 5 years ago by jdemeyer

Is it possible to also remove the non-standard uses of \ line continuations, see #14512.

comment:27 Changed 5 years ago by git

  • Commit changed from b0bebd69b21c0c0044938d6600afd860fb999abf to 856f0ce66e42ecb276bf6998b5a27cfcb73cb97f

Branch pushed to git repo; I updated commit sha1. New commits:

64791abMerge branch 'u/chapoton/12822' of trac.sagemath.org:sage into portugal
856f0cetrac #12822 removing obsolete \ continuation

comment:28 Changed 5 years ago by git

  • Commit changed from 856f0ce66e42ecb276bf6998b5a27cfcb73cb97f to dc9bb19003020abac43f60d8b93e242336c4529c

Branch pushed to git repo; I updated commit sha1. New commits:

dc9bb19trac #12822 one more \ missed

comment:29 follow-up: Changed 5 years ago by kcrisman

Anyone have a sense of what is still needed here? It's rather impressively complete.

comment:30 in reply to: ↑ 29 Changed 5 years ago by goliveira

Replying to kcrisman:

Anyone have a sense of what is still needed here? It's rather impressively complete.

In the file latex.rst, there are references to the obsolete jsMath, which was replaced by MathJax? in more recent versions. This has to be updated in the translation.

You are right, the above report is not clear at all (but thanks to the people that worked on this nevertheless). I think that the other issues that were raised are solved. For instance, the presence of obsolete \ to break lines, and old notation for line continuation in the sage prompt. I did a search on the files and I believe this is solved.

As far as I know, the only remaining issue is the reference to the obsolete jsMath. (I am going to fix this until the end of the week.)

comment:31 Changed 5 years ago by kcrisman

As far as I know, the only remaining issue is the reference to the obsolete jsMath. (I am going to fix this until the end of the week.)

Sorry, I should have asked whether there was anything linguistic, but I think comment:10 answers that. Awesome, and thanks for fixing this. Then we can add it a link on the website as well - see http://www.sagemath.org/pt/ for a totally different, but apparently useful, tutorial.

comment:32 Changed 5 years ago by git

  • Commit changed from dc9bb19003020abac43f60d8b93e242336c4529c to 5fa1b0ddabb9f5f33760487477d44c53efa00140

Branch pushed to git repo; I updated commit sha1. New commits:

d21d726Merge branch 'u/chapoton/12822' into 6.6.b0
5fa1b0dtrac #12822 replaced jsmath by mathjax in latex.rst

comment:33 Changed 5 years ago by kcrisman

  • Reviewers changed from Paulo César Pereira de Andrade to Paulo César Pereira de Andrade, Jeroen Demeyer, Frédéric Chapoton

comment:34 Changed 5 years ago by kcrisman

  • Reviewers changed from Paulo César Pereira de Andrade, Jeroen Demeyer, Frédéric Chapoton to Paulo César Pereira de Andrade, Jeroen Demeyer, Frédéric Chapoton, Karl-Dieter Crisman
  • Status changed from needs_review to needs_work

This apparently makes several graphics files while being tested. Can you look into this?

Also, there is a bad link - dive into Python now is at http://www.diveintopython.net/

Martin Albrecht (malb@…) is probably old, though also probably still in the regular tutorial.

Finally, numerous doctest failures - mostly trivial related to graphics, but quite a few others related to Pari and other stuff as well.

Version 0, edited 5 years ago by kcrisman (next)

comment:35 Changed 5 years ago by jdemeyer

Also, shouldn't comment like # automatic coercion before addition be translated too?

comment:36 Changed 5 years ago by git

  • Commit changed from 5fa1b0ddabb9f5f33760487477d44c53efa00140 to d15374c9cd4851145fc125d75c24cd8bb6927e6e

Branch pushed to git repo; I updated commit sha1. New commits:

f3cc689trac #12822 fixing links, and plot doctests
d15374ctrac #12822 correcting all doctests

comment:37 Changed 5 years ago by chapoton

I think I have taken care of

  • created graphics
  • bad links and addresses
  • failing doctests

There remains the question of traduction of comments.

comment:38 Changed 5 years ago by chapoton

  • Milestone changed from sage-6.4 to sage-6.6

comment:39 Changed 5 years ago by kcrisman

**********************************************************************
File "src/doc/pt/tutorial/programming.rst", line 512, in doc.pt.tutorial.programming
Failed example:
    X
Expected:
    {1, 19, 'a'}
Got:
    {'a', 1, 19}

This is because sets don't print deterministically.

https://docs.python.org/ref/ref.html doesn't work either, nor does http://ipython.scipy.org/doc/rel-0.9.1/html/interactive/reference.html#magic-commands (a link in interactive_shell.html) ... sigh, I don't have time to just click on every link! And sage -docbuild --warn-links I think only works for internal links.

comment:40 Changed 5 years ago by git

  • Commit changed from d15374c9cd4851145fc125d75c24cd8bb6927e6e to d3540f32172cbd154ff37cd70e3b0734412c301a

Branch pushed to git repo; I updated commit sha1. New commits:

d3540f3trac #12822 set order is random, corrected html links

comment:41 Changed 5 years ago by git

  • Commit changed from d3540f32172cbd154ff37cd70e3b0734412c301a to 429d63af85140282617e1df16567845001a77f1f

Branch pushed to git repo; I updated commit sha1. New commits:

429d63atrac # ipython version typo

comment:42 Changed 5 years ago by kcrisman

How do we deal with other set output? Maybe list(set)? After all,

sage: Y
{2/3, 1}

may be different on other systems, I assume. Thoughts/opinions?

comment:43 Changed 5 years ago by git

  • Commit changed from 429d63af85140282617e1df16567845001a77f1f to 61fdeb577cc6a043bb2f0013a7835e74b7b0fb30

Branch pushed to git repo; I updated commit sha1. New commits:

61fdeb5trac #12822 sets are printed in random order (bis)

comment:44 follow-up: Changed 5 years ago by kcrisman

  • Cc jhpalmieri jdemeyer added

Whenever I do the docbuild with --warn-links I get

[tutorial ] /Users/.../sage/src/doc/pt/tutorial/interactive_shell.rst:403: WARNING: envvar reference target not found: EDITOR

but not without that, and not if I docbuild a second time. I'm not sure if that matters, unless perhaps we no longer have an EDITOR variable? I'm cc:ing a couple people who know what that flag does better than I do.

comment:45 Changed 5 years ago by kcrisman

https://docs.python.org/devguide/ seems to be the best link nowadays for the way one actually develops Python, I couldn't even easily find "Guido, Some Guys, and a Mailing List: How Python is Developed" on the official Python site.

http://sagemath.org/doc/thematic_tutorials/coercion_and_categories.html is the new link for tour_coercion.html and of course the Portuguese for that link ( como um arquivo Sage.) would not be quite right.

altermundus link is now http://altermundus.com/pages/tkz/graph/ (in latex.html)

Both links to the Python documentation at programming.html#dicionarios are dead

sagetex.html has (este link deve levá-lo a uma cópia local do guia de instalação para mais informações de como proceder. but in any case "este link" is wrong because there is no pt installation guide. I say remove that whole bit.

Sorry for the laundry list, but I find that you and I have a good workflow on this sort of thing! It's really very close to being done, thanks for helping shepherd some of these less-popular tickets to completion.

comment:46 Changed 5 years ago by kcrisman

(Which is all to say that these are cosmetic changes intended to make sure that users coming to this aren't confronted with tons of bad links; this is basically ready to go.)

comment:47 Changed 5 years ago by git

  • Commit changed from 61fdeb577cc6a043bb2f0013a7835e74b7b0fb30 to 9dc3771aea869eaa342c98e535bc3d7681af2230

Branch pushed to git repo; I updated commit sha1. New commits:

9dc3771trac #12822 more care about the links

comment:48 in reply to: ↑ 44 Changed 5 years ago by jhpalmieri

Replying to kcrisman:

Whenever I do the docbuild with --warn-links I get

[tutorial ] /Users/.../sage/src/doc/pt/tutorial/interactive_shell.rst:403: WARNING: envvar reference target not found: EDITOR

but not without that, and not if I docbuild a second time. I'm not sure if that matters, unless perhaps we no longer have an EDITOR variable? I'm cc:ing a couple people who know what that flag does better than I do.

I don't think this matters. The issue is that :envvar:`EDITOR` can create a cross-reference to an entry in a construction like .. envvar:: name. We only use the :envvar:`...` markup to typeset environment variables consistently, not for the cross-referencing. So in fact you will get lots of such errors if you build the installation manual with --warn-links, because there are lots of environment variables discussed there.

comment:49 Changed 5 years ago by kcrisman

  • Status changed from needs_work to positive_review

Okay, then anything else I saw is also a problem in the actual tutorial, soooo let's get this in!!! Awesome.

comment:50 Changed 5 years ago by vbraun

  • Branch changed from u/chapoton/12822 to 9dc3771aea869eaa342c98e535bc3d7681af2230
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.