Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#12818 closed defect (duplicate)

Building polybori under FreeBSD

Reported by: stephen Owned by: pjeremy
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: BSD Keywords: FreeBSD polybori
Cc: AlexanderDreyer Merged in:
Authors: Reviewers: Stephen Montgomery-Smith, Alexander Dreyer, Karl-Dieter Crisman
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: #13124 Stopgaps:

Status badges

Description (last modified by chapoton)

I need this patch to build under FreeBSD:

--- src/polybori-0.8.0/Cudd/cudd/cudd.h-orig 2012-02-09 03:18:02.000000000 +0000
+++ src/polybori-0.8.0/Cudd/cudd/cudd.h 2012-02-09 03:19:20.000000000 +0000
@@ -82,6 +82,12 @@
 
 #endif
 
+#ifdef __cplusplus
+#include <cstdio>
+#else
+#include <stdio.h>
+#endif
+
 #ifdef __cplusplus
 extern "C" {
 #endif

This patch should be harmless to all builds under other OS.


Duplicate of #13124.

Attachments (2)

Cudd.cudd.cudd.h (306 bytes) - added by stephen 9 years ago.
patch for cudd.h
spkg-patch-polybori-0.8.0.p2_-_spkg_install (436 bytes) - added by stephen 9 years ago.
patch for spkg-install

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by stephen

patch for cudd.h

Changed 9 years ago by stephen

patch for spkg-install

comment:1 Changed 9 years ago by stephen

  • Component changed from PLEASE CHANGE to FreeBSD
  • Owner changed from tbd to pjeremy
  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 9 years ago by AlexanderDreyer

  • Cc AlexanderDreyer added
  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.

Thanks, the patch will be part of polybori-0.8.2, see https://bitbucket.org/brickenstein/polybori/changeset/8aed782d9baf .

comment:3 Changed 9 years ago by kcrisman

  • Authors set to Stephen Montgomery-Smith
  • Reviewers set to Alexander Dreyer

Is there an ETA on when that will be in Sage, or should we try to make an spkg update?

comment:4 Changed 9 years ago by AlexanderDreyer

Meanwhile the new spkg is at #13124. Feel free to try it out. If it solves you problem, this one may be considered as a duplicate of #13124.

comment:5 Changed 9 years ago by kcrisman

  • Reviewers changed from Alexander Dreyer to Alexander Dreyer, Karl-Dieter Crisman
  • Status changed from new to needs_review

I can confirm that the patch in question is included in #13124. Since this is definitely the only thing from the FreeBSD port list from polybori, I think that we can close this ticket.

comment:6 Changed 9 years ago by kcrisman

  • Dependencies set to #13124
  • Status changed from needs_review to positive_review

comment:7 Changed 9 years ago by kcrisman

  • Milestone changed from sage-5.1 to sage-5.2

comment:8 Changed 9 years ago by stephen

I can confirm that ticket #13124 fixes this problem for FreeBSD.

comment:9 Changed 9 years ago by AlexanderDreyer

  • Description modified (diff)
  • Milestone changed from sage-5.2 to sage-duplicate/invalid/wontfix

Duplicate of #13124.

comment:10 Changed 9 years ago by jdemeyer

  • Authors Stephen Montgomery-Smith deleted
  • Resolution set to duplicate
  • Reviewers changed from Alexander Dreyer, Karl-Dieter Crisman to Stephen Montgomery-Smith, Alexander Dreyer, Karl-Dieter Crisman
  • Status changed from positive_review to closed

comment:11 Changed 5 years ago by chapoton

comment:12 Changed 5 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.