Opened 8 years ago

Closed 20 months ago

#12720 closed enhancement (duplicate)

Add speed regression database to doctesting

Reported by: roed Owned by: roed
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest framework Keywords:
Cc: vdelecroix, mderickx, embray, roed Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by roed)

Currently there's no systematic way of detecting whether a change to the sage library drastically slows down some function (perhaps even the function that's being updated in a ticket).

This ticket aims to add features to the new doctesting code at #12415 that provide the option to run doctests in a mode where they add timing data to a database.

Apply 12720.patch

Apply 12720_script.patch to the script repo

Attachments (2)

12720.patch (56.6 KB) - added by roed 7 years ago.
Still very much in progress
12720_script.patch (1.0 KB) - added by roed 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 7 years ago by jhpalmieri

Could monitoring Sage's startup time be incorporated into this?

comment:2 Changed 7 years ago by roed

  • Dependencies changed from #12415 to #13278

Changed 7 years ago by roed

Still very much in progress

Changed 7 years ago by roed

comment:3 Changed 7 years ago by roed

  • Description modified (diff)

comment:4 Changed 7 years ago by roed

Now that #12415 is in Sage, I'll be working on this some. It will probably be at least a few weeks though (I'm going to be working on p-adics and the git transition first).

In the mean time, I've updated the patches to apply against #12415 (actually, rebased against #13278). There's still a lot to be done to make them work well.

comment:5 Changed 7 years ago by roed

  • Component changed from doctest to doctest framework
  • Owner changed from mvngu to roed

comment:6 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:7 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:8 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:9 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:10 Changed 5 years ago by vdelecroix

  • Cc vdelecroix added

Hello,

just cc'ing me!

comment:11 Changed 2 years ago by mderickx

  • Cc mderickx added

comment:12 Changed 20 months ago by jdemeyer

  • Cc embray roed added
  • Dependencies changed from #13278 to #24655
  • Milestone changed from sage-6.4 to sage-8.2

comment:13 Changed 20 months ago by saraedum

roed, I believe that this should probably be closed. The approach of rolling our own system for doing something that asv does very well is probably not appropriate anymore. What do you think?

comment:14 Changed 20 months ago by jdemeyer

  • Dependencies #24655 deleted
  • Milestone changed from sage-8.2 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25262

Note: See TracTickets for help on using tickets.