Changes between Version 37 and Version 44 of Ticket #12719


Ignore:
Timestamp:
05/26/12 17:50:45 (9 years ago)
Author:
vbraun
Comment:

The new ipython configuration files are once more incompatible with the previous ones. My patch versions the directory now (that is, it is named .sage/ipython-VERSION) and deletes the SAGE_ROOT/ipythonrc stuff. I think all sage-specific configuration should go into sage/misc/interface.py

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #12719

    • Property Status changed from needs_review to needs_work
    • Property Keywords sd40.5 added
  • Ticket #12719 – Description

    v37 v44  
    11We need to upgrade IPython to the shiny new thing. Well, not really - the shiny new thing was 0.11, and 0.12 is now stable. It's been mostly rewritten and is now a lot more modular, as I understand it. Definitely worth using in Sage.
     2
     3Note: To use the QT console (`sage -ipython qtconsole`), you need qt/qt-devel in your base OS install, the optional zeromq/pyzmq spkgs from #12843, and the optional sip/PyQt spkgs from #13022.
    24
    35Install IPython 0.12.1: spkg at [[http://sage.math.washington.edu/home/jason/ipython-0.12.1.spkg]]
     
    57'''apply''':
    68
    7 To the scripts repository: [attachment:trac_12719-scripts.patch]
     9To the scripts repository:
     10 * [attachment:trac_12719-scripts.patch]
     11
     12To the root repository:
     13 * [attachment:trac_13013_ROOT_configuration_files.patch]
    814
    915To the sage library:
    10 
    11  1. [attachment:trac_12719.patch]
    12  1. [attachment:trac_12719-move_to_preparser.patch]
     16 * [attachment:trac_12719.patch]
     17 * [attachment:trac_12719-move_to_preparser.patch]