Changes between Initial Version and Version 7 of Ticket #12661


Ignore:
Timestamp:
03/13/12 13:23:29 (10 years ago)
Author:
SimonKing
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #12661

    • Property Keywords gmp added
    • Property Status changed from new to needs_review
    • Property Summary changed from Fix optional gmp package on openSuse to Upgrade the optional GMP package
    • Property Authors changed from to Simon King
  • Ticket #12661 – Description

    initial v7  
    1 The optional gmp-4.2.1 package fails to build on my laptop,
    2 {{{
    3 (sage subshell) linux-sqwp:sage-5.0.beta7 simon$ uname -a
    4 Linux linux-sqwp.site 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64 x86_64 x86_64 GNU/Linux
    5 SAGE_ROOT=/home/simon/SAGE/sage-5.0.beta7
    6 (sage subshell) linux-sqwp:sage-5.0.beta7 simon$ cat /etc/issue
    7 Welcome to openSUSE 12.1 "Asparagus" - Kernel \r (\l).
    8 }}}
     1The optional gmp-4.2.1 package fails to build on my openSuse laptop,
    92
    10 Here is [http://sage.math.washington.edu/home/SimonKing/logs/gmp.log the log] from installing the package.
     3I succeeded to fix it, in the sense that it did build. However, the tests did not pass.
    114
    12 Note that I have already added the `--libdir` option when spkg-install calls `./configure` (that was needed for many other packages on openSuse, see #12313), but it was not enough to solve the problem, and the error without my change looked the same.
     5Therefore I suggest to upgrade the optional gmp package to the latest upstream release.
     6
     7It turns out that the ''unpatched'' upstream code installs and tests fine on my laptop. However, the old gmp spkg was massively patched, for various reasons. I don't know if all of the fixes from the old spkg went upstream.
     8
     9Therefore, I hope that some experts can check on various machines and in various settings, to see whether some of the old patches are still needed.
     10
     11Note that the old `SPKG.txt` remarks that the spkg-install of the optional polymake spkg needs to be updated, if gmp is upgraded. I hope that someone can do that.
     12
     13Install http://sage.math.washington.edu/home/SimonKing/SAGE/spkgs/gmp-5.0.4.spkg