Opened 8 years ago

Closed 5 years ago

#12660 closed enhancement (duplicate)

make raising polynomials in characteristic p to large powers (and printing them) more efficient

Reported by: was Owned by: malb
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage: R.<x> = GF(5)[]
sage: (1+x)^(5^2)
x^25 + 1
sage: (1+x)^(5^3)     # 
x^125 + 1
sage: f = (x+1)^(5^8)
sage: f = (x+1)^(5^9)
sage: f = (x+1)^(5^10)    # quite slow
sage: f
WAIT A WHILE
^C^C^C^C^C^C^C^C
-

One could similarly optimize multivariate polynomial powering.

Change History (9)

comment:1 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 5 years ago by bruno

This seems duplicate of #7253. Should maybe close one of the tickets.

comment:6 Changed 5 years ago by bruno

  • Status changed from new to needs_info

comment:7 Changed 5 years ago by bruno

  • Status changed from needs_info to positive_review

comment:8 Changed 5 years ago by bruno

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix

I put a positive review to close this ticket since #7253 has the exact same purpose.

comment:9 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.