Opened 9 years ago

Closed 9 years ago

#12654 closed defect (duplicate)

polybori crash (Linux)

Reported by: cbwolf Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: polybori multivariate quadratic polynomials
Cc: AlexanderDreyer Merged in:
Authors: Reviewers: Alexander Dreyer
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by AlexanderDreyer)

Hello,

I think I found a bug in Sage 4.8, more specifically in polybori. Polybori terminates with a "segmentation fault". I have attached the input (sparse polynomials) and the output. I can reproduce the error with this specific input.

For smaller instances (i.e. less variables, less equations), the programme runs fine and the output is correct.

The machine has about 256 GB RAM, uses an AMD Opteron(TM) Processor 6276 @ 2.3 GHz and runs under Linux 2.6.32-220.2.1.el6.x86_64.

If you need any more info: Please drop me a line!

Best, Christopher


Duplicate of #11575.

Attachments (3)

ticketMinimal.sage (583.3 KB) - added by cbwolf 9 years ago.
Minimal Input that makes polybori crash
testOut.txt (6.0 KB) - added by cbwolf 9 years ago.
Output of the test file
testError.txt (292 bytes) - added by cbwolf 9 years ago.
Error message of the test file

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by cbwolf

Minimal Input that makes polybori crash

Changed 9 years ago by cbwolf

Output of the test file

Changed 9 years ago by cbwolf

Error message of the test file

comment:1 follow-up: Changed 9 years ago by AlexanderDreyer

  • Cc AlexanderDreyer added
  • Keywords polybori added; polibori removed
  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.
  • Status changed from new to needs_info

It seems that this is fixed by #12655 or #12656 (for sage-5.0alpha). Can you verify this?

comment:2 in reply to: ↑ 1 Changed 9 years ago by AlexanderDreyer

Replying to AlexanderDreyer:

It seems that this is fixed by #12655 or #12656 (for sage-5.0alpha). Can you verify this?

Maybe #11575 already fixed that (still it works only for sage-5.0).

comment:3 Changed 9 years ago by cbwolf

Thanks for pointing this out!

Yes, the bug is gone with sage-5.0beta_a11.

Best, Christopher

comment:4 Changed 9 years ago by AlexanderDreyer

  • Status changed from needs_info to needs_review

Duplicate of #11575.

comment:5 Changed 9 years ago by AlexanderDreyer

  • Description modified (diff)
  • Status changed from needs_review to positive_review

Abusing "positive review", because I cannot close it.

comment:6 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Reviewers set to Alexander Dreyer

In such cases, you should set the milestone to "sage-duplicate/invalid/wontfix".

comment:7 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.