Opened 7 years ago

Closed 5 years ago

#12639 closed defect (duplicate)

The sage-env script doesn't respect PYTHONPATH

Reported by: Snark Owned by: leif
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: Merged in:
Authors: Julien Puydt Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I was hacking happily in python in a directory. Then I decided I wanted to use that code with sage, and set PYTHONPATH to point to it. And sage still didn't find it...

The reason is that sage-env overwrites PYTHONPATH instead of prepending to it.

Attachments (1)

trac-12639.patch (657 bytes) - added by Snark 7 years ago.
Patch to make sage-env respect PYTHONPATH

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by Snark

Patch to make sage-env respect PYTHONPATH

comment:1 Changed 7 years ago by Snark

  • Status changed from new to needs_review

comment:2 follow-up: Changed 7 years ago by mhansen

See #3784

comment:3 in reply to: ↑ 2 Changed 7 years ago by jhpalmieri

Replying to mhansen:

See #3784

In more detail: first, use SAGE_PATH for this rather than PYTHONPATH. Second, this ticket should probably be closed as invalid or as a duplicate of #3784.

comment:4 Changed 7 years ago by jdemeyer

Please fill in your real name as Author.

comment:5 Changed 7 years ago by leif

  • Authors set to Julien Puydt

comment:6 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:7 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:8 Changed 5 years ago by rws

  • Status changed from needs_review to needs_info

Needs info from reporter if SAGE_PATH solves his problem.

comment:9 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:10 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:11 Changed 5 years ago by chapoton

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from needs_info to needs_review

duplicate of #3784 : please use SAGE_PATH for this

comment:12 Changed 5 years ago by aapitzsch

  • Status changed from needs_review to positive_review

comment:13 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.