Changes between Initial Version and Version 1 of Ticket #12627, comment 42


Ignore:
Timestamp:
12/17/13 21:49:14 (5 years ago)
Author:
vbraun
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #12627, comment 42

    initial v1  
    1 I'm not sure the [comment:7 issues in comment 7] were ever really resolved. Rather than merging this right away, it might be good to discuss it on sage-devel first. There are at least two issues:
     1- if you run `sage --kash`, should it run a system version of kash if Sage's optional kash spkg hasn't been installed, or not?
    22
    3 - if you run `sage --kash`, should it run a system version of kash if Sage's optional kash spkg hasn't been installed, or not?
     3DWIM (http://en.wikipedia.org/wiki/DWIM) is pretty unambiguous here. Having typed that command, do I want kash to run or do I want to get some obscure error even though kash is actually on my computer?
     4
    45- in the old version there was some redundancy: the path to `gap`, for example, was explicit, to make sure that Sage's version of GAP was used. Is this redundancy important?
    56
    6 Also, the positive review is not appropriate, since the [comment:21 issue in comment 21] was not fixed: the message for `sage --help` says that `sage --M2` (for example) runs "Sage's Macaulay2", but this is no longer accurate with the current patch.
     7Thats really just a corollary to the first point---we should make the best effort to get gap up and running, otherwise our user interface is crap.
     8
     9- the message for `sage --help` says that `sage --M2` (for example) runs "Sage's Macaulay2", but this is no longer accurate with the current patch.
     10
     11This is now #15538