Opened 9 years ago

Closed 9 years ago

#12621 closed defect (duplicate)

use bash for prereq install file

Reported by: jhpalmieri Owned by: GeorgSWeber
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #4949 Stopgaps:

Status badges

Description (last modified by jdemeyer)

The script prereq-0.9-install starts with the line

#!/bin/sh

As a result, when installing prereq on a Solaris machine, I see this:

Starting prerequisite check.
Machine: SunOS mark2 5.10 Generic_127111-01 sun4u sparc SUNW,Sun-Blade-2500
base/prereq-0.9-install: !: not found
checking for a BSD-compatible install... ./install-sh -c

I think this is because of the line

if ! [ -f "$SAGE_ROOT/spkg/base/$TARGET.tar" ]; then

in prereq-0.9-install. Using bash to run this script instead of sh fixes the problem. So I propose using bash for this script.

This will be fixed in #12112.

Attachments (2)

trac_12621-prereq.patch (1.2 KB) - added by jhpalmieri 9 years ago.
trac_12621-prereq.v2.patch (654 bytes) - added by jhpalmieri 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by jhpalmieri

comment:1 Changed 9 years ago by jhpalmieri

  • Dependencies set to #4949
  • Description modified (diff)
  • Status changed from new to needs_review

Changed 9 years ago by jhpalmieri

comment:2 Changed 9 years ago by jhpalmieri

  • Description modified (diff)
  • Summary changed from use bash for prereq and bzip2 install files to use bash for prereq install file

comment:3 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.