Opened 9 years ago

Closed 9 years ago

#12617 closed enhancement (fixed)

Update Cremona's table of elliptic curves

Reported by: cremona Owned by: tbd
Priority: major Milestone: sage-5.0
Component: packages: optional Keywords: elliptic curve database, rd2, database
Cc: ohanar Merged in: sage-5.0.beta10
Authors: R. Andrew Ohana Reviewers: John Cremona, Jennifer Balakrishnan
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by cremona)

The optional spkg database_cremona_ellcurve-20120113.spkg needs to be updated to include the conductor range 220000-230000.


Updated spkg: http://wstein.org/home/ohanar/cremona-database/database_cremona_ellcurve-20120302.spkg

Apply patch trac_12167-ec.patch

Attachments (1)

trac_12167-ec.patch (920 bytes) - added by cremona 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by ohanar

  • Authors set to R. Andrew Ohana
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 9 years ago by cremona

  • Reviewers set to John Cremona

Thanks -- testing now.

Changed 9 years ago by cremona

comment:3 Changed 9 years ago by cremona

  • Description modified (diff)

The patch fixes a problem testing sage/doc/en/bordeaux/elliptic_curves.rst caused by new curves in the database with generators different from those computed on the fly.

I give a positive review to the spkg; anyone who approves of my small patch can set the ticket to positive review.

comment:4 Changed 9 years ago by jen

  • Reviewers changed from John Cremona to John Cremona, Jennifer Balakrishnan
  • Status changed from needs_review to positive_review

The patch to the documentation looks good. Positive review.

comment:5 Changed 9 years ago by jen

  • Keywords rd2 added

comment:6 Changed 9 years ago by jen

  • Keywords changed from elliptic curve database, rd2 to elliptic curve database, rd2, database

comment:7 Changed 9 years ago by jdemeyer

  • Merged in set to sage-5.0.beta10
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.