Opened 14 years ago

Closed 13 years ago

#1255 closed defect (invalid)

[is invalid.] bug in permutation_automorphism_group

Reported by: wdj Owned by: wdj
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: coding theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I have found a code C which crashes C.permutation_automorphism_group(). This function basically is a wrapper for GAP's MatrixAutomorphisms function. The code that causes it to fail is [20,14] in http://sage.math.washington.edu/home/wdj/research/coding-theory/sd_codes.sage

Change History (7)

comment:1 Changed 14 years ago by was

Is this a bug in gap? If so, make a Gap-only session that replicates it and report it to the Gap list asap.

comment:2 Changed 14 years ago by was

We are having trouble replicating this -- what hardware / os are you using?

comment:3 Changed 14 years ago by mabshoff

  • Milestone changed from sage-2.10 to sage-2.9.1

comment:4 Changed 14 years ago by rlm

  • Summary changed from bug in permutation_automorphism_group to [is invalid?] bug in permutation_automorphism_group

This definitely doesn't seem valid anymore:

sage: load /Users/rlmill/Desktop/sd_codes.sage
sage: time L = self_dual_codes(20)
CPU times: user 2.09 s, sys: 0.83 s, total: 2.92 s
Wall time: 3.10
sage: C = L[14][0]; C
Linear code of length 19, dimension 10 over Finite Field of size 2
sage: C.permutation_automorphism_group()
Permutation Group with generators [(10,19), (9,15)(16,17), (9,16)(15,17), (8,9)(17,18), (7,8)(16,17), (4,5)(13,14), (4,13)(5,14), (3,4)(12,14), (1,2)(5,13), (1,3)(2,12)]

comment:5 Changed 14 years ago by rlm

In fact, none of the codes from that function cause a "crash":

sage: for n in range(24):
....:     for C in self_dual_codes(n):
....:         G = C[0].permutation_automorphism_group()
....:         
sage: 

comment:6 Changed 14 years ago by rlm

  • Summary changed from [is invalid?] bug in permutation_automorphism_group to [is invalid.] bug in permutation_automorphism_group

David also says that he cannot reproduce the crash.

comment:7 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.1.2 to sage-duplicate/invalid
  • Resolution set to invalid
  • Status changed from new to closed

Invalid.

Cheers,

Michael

Note: See TracTickets for help on using tickets.