Opened 11 years ago

Closed 10 years ago

#12516 closed defect (worksforme)

Cython compile error in optional package p_group_cohomology-2.0.spkg

Reported by: Mariah Lennox Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On skynet/eno using gcc-4.6.2, the optional package p_group_cohomology-2.0.spkg fails to install in sage-4.8 with the following error:

gcc -pthread -shared build/temp.linux-x86_64-2.6/pGroupCohomology/modular_cohomology.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/aufloesung.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/aufnahme.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/djgerr.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/fileplus.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/nBuchberger.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/pgroup.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/pincl.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/slice.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/urbild.o build/temp.linux-x86_64-2.6/pGroupCohomology/c_sources/uvr.o -L/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc/local/lib -lmtx -lpython2.6 -o build/lib.linux-x86_64-2.6/pGroupCohomology/modular_cohomology.so
cythoning pGroupCohomology/cochain.pyx to pGroupCohomology/cochain.c

Error compiling Cython file:
------------------------------------------------------------
...
            elif isinstance(C,MODCOCH):
                P = self.parent()
                if P is not C.parent():
                    return True
                try:
                    br = singular('basering')
                                ^
------------------------------------------------------------

pGroupCohomology/cochain.pyx:1037:33: local variable 'singular' referenced before assignment
building 'pGroupCohomology.cochain' extension
gcc -fno-strict-aliasing -g -O2 -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc-optional/local/include/csage/ -I/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc-optional/devel/sage/ -I/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc-optional/devel/sage/c_lib -I/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc-optional/devel/sage/sage/ext -Imtx2.2.4/src/ -IpGroupCohomology/c_sources -IpGroupCohomology -I/home/mariah/sage/sage-4.8-x86_64-Linux-core2-fc-optional/local/include/python2.6 -c pGroupCohomology/cochain.c -o build/temp.linux-x86_64-2.6/pGroupCohomology/cochain.o
pGroupCohomology/cochain.c:1:2: error: #error Do not use this file, it is the result of a failed Cython compilation.
error: command 'gcc' failed with exit status 1

real    4m21.321s
user    3m56.276s
sys     0m6.743s
************************************************************************
Error installing package p_group_cohomology-2.0
************************************************************************

Change History (4)

comment:1 Changed 10 years ago by Simon King

Milestone: sage-5.6sage-duplicate/invalid/wontfix

Why didn't you cc me? Anyway, I suppose the problem is fixed in the most recent package version, see #13295.

comment:2 Changed 10 years ago by Travis Scrimshaw

Reviewers: Travis Scrimshaw
Status: newneeds_review

comment:3 Changed 10 years ago by Travis Scrimshaw

Status: needs_reviewpositive_review

comment:4 Changed 10 years ago by Jeroen Demeyer

Resolution: worksforme
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.