Opened 14 years ago

Closed 14 years ago

#1247 closed defect (fixed)

cremona-20071116.p0.spkg fails to build with gcc 4.2.x

Reported by: mabshoff Owned by: mabshoff
Priority: major Milestone: sage-2.8.14
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Andrzej Giniewicz reported:

 not counting plenty (281) warnings in file curvesort.cc (about
deprecated conversion from string constant to 'char*') I also get
WHOLE lot (about 8000) errors all in one nature:

../g0n/curvesort.cc:106: error: jump to case label
../g0n/curvesort.cc:105: error:   crosses initialization of 'int
<anonymous>[3]'

with different numbers only... problems starts from:

g++ -c -fPIC -g -O2 -DNEW_OP_ORDER -DUSE_PARI_FACTORING -I../include -
DNTL_ALL -I/opt/sage/local/include -I/opt/sage/local/include  tsat3.cc
-o tsat3_n.o
In file included from tsat3.cc:37:
../g0n/curvesort.cc ....... etc etc

I think there is no sense to attach such big report... I'm running
current Arch Linux, that is GCC 4.2.2, gLibc 2.7, kernel 2.6.23.8. Is
there some workaround? 

See http://groups.google.com/group/sage-support/t/c2140ece9608358e

Cheers,

Michael

Change History (7)

comment:1 Changed 14 years ago by mabshoff

  • Status changed from new to assigned

comment:2 Changed 14 years ago by mabshoff

  • Summary changed from cremona-20071116.p0.spkg fails to build on Arch linux, 32bit linux, gcc-4.2.2 to cremona-20071116.p0.spkg fails to build on Arch linux, x86, gcc-4.2.2 and OpenSuSE 10.2, x86-64, gcc 4.2.1

There is also an issue on OpenSuSE 10.2:

You mention that there is an issue with cremona.spkg on Linux/Itanium with
older gcc and also Solaris. My settings are:
- openSUSE 10.2 (X86-64),
- AMD Athlon(tm) 64 Processor 3700+
- gcc-Version 4.2.1; I think this isn't exactly old, or is it? 

See http://groups.google.com/group/sage-support/t/8e446357a1d15a8a

Cheers,

Michael

comment:3 Changed 14 years ago by mabshoff

  • Summary changed from cremona-20071116.p0.spkg fails to build on Arch linux, x86, gcc-4.2.2 and OpenSuSE 10.2, x86-64, gcc 4.2.1 to cremona-20071116.p0.spkg fails to build with gcc 4.2.x

comment:4 Changed 14 years ago by mabshoff

  • Milestone changed from sage-2.8.15 to sage-2.8.14

comment:5 Changed 14 years ago by mabshoff

There is a new cremona.spkg that should work with gcc 4.2.x at

http://sage.math.washington.edu/home/mabshoff/cremona-20071124.spkg

Cheers,

Michael

comment:6 Changed 14 years ago by mabshoff

The bundle applied also includes #1238. So close that too when closing this ticket.

Cheers,

Michael

comment:7 Changed 14 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in 2.8.14.rc0. Feedback provided by various people indicates that the problem is fixed.

Cheers,

Michael

Note: See TracTickets for help on using tickets.