Opened 9 years ago

Closed 8 years ago

#12458 closed enhancement (duplicate)

remove references to deprecated RQDF

Reported by: zimmerma Owned by: AlexGhitza
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: roed, jdemeyer Merged in:
Authors: Reviewers: Paul Zimmermann
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

In Sage 4.8:

sage: search_src("RQDF")
symbolic/constants.py:175:- Didier Deshommes (2007-03-27): added constants from RQDF (deprecated)
rings/all.py:87:# from real_rqdf import RealQuadDoubleField, RQDF, QuadDoubleElement
rings/real_mpfr.pyx:4960:    elif type == "RQDF":
rings/real_mpfr.pyx:4961:        from real_rqdf import RQDF
rings/real_mpfr.pyx:4962:        return RQDF
misc/explain_pickle.py:2410:#         doctest:...: DeprecationWarning: RQDF is deprecated; use RealField(212) instead.
misc/explain_pickle.py:2411:#         doctest:...: DeprecationWarning: RQDF is deprecated; use RealField(212) instead.
misc/explain_pickle.py:2412:#         doctest:...: DeprecationWarning: RQDF is deprecated; use RealField(212) instead.

Duplicate of #13037.

Change History (6)

comment:1 Changed 8 years ago by tscrim

  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This was done at some point before 5.5.rc0:

travis@travis-virtualbox:~/sage-5.5.rc0/devel/sage-combinat/sage/combinat$ cd ../rings/
travis@travis-virtualbox:~/sage-5.5.rc0/devel/sage-combinat/sage/rings$ ls real*real_double.c    real_interval_absolute.c    real_lazy.pxd  real_mpfi.pyx
real_double.pxd  real_interval_absolute.pyx  real_lazy.pyx  real_mpfr.c
real_double.pxi  real_interval_field.py      real_mpfi.c    real_mpfr.pxd
real_double.pyx  real_lazy.c                 real_mpfi.pxd  real_mpfr.pyx
travis@travis-virtualbox:~/sage-5.5.rc0/devel/sage-combinat/sage/rings$ grep "RQDF" *

comment:2 Changed 8 years ago by zimmerma

  • Cc jdemeyer added
  • Reviewers set to Paul Zimmermann
  • Status changed from needs_review to positive_review

this is indeed fixed now. Thanks for looking at it. Jeroen, should we put "tscrim" as author?

Paul

comment:3 follow-up: Changed 8 years ago by jdemeyer

  • Description modified (diff)

No, duplicate tickets cannot have an author since there is nothing to be the author of.

comment:4 in reply to: ↑ 3 Changed 8 years ago by zimmerma

Replying to jdemeyer:

No, duplicate tickets cannot have an author since there is nothing to be the author of.

ok. Nevertheless, "tscrim", please put your real name on trac.sagemath.org so that we can identify you for other tickets.

Paul

comment:5 Changed 8 years ago by tscrim

Changed.

Best,
Travis

comment:6 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.