Opened 11 years ago

Closed 11 years ago

#12457 closed defect (wontfix)

Problems with C++ exception handling on OS X with custom GCC

Reported by: Jeroen Demeyer Owned by: David Kirkby
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

The problem is that a custom built GCC (#12369) links different standard libraries than Apple's GCC. In particular, it seems that "-lgcc_s" and "-lgcc_eh" are never linked in by Apple. We should change our linker flags to do the same.

This seems to affect only the Sage library. The problem is not limited to OS X 10.7, it happens also on 10.6.

Attachments (1)

12457_darwin_link.patch (732 bytes) - added by Jeroen Demeyer 11 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Description: modified (diff)

Changed 11 years ago by Jeroen Demeyer

Attachment: 12457_darwin_link.patch added

comment:2 Changed 11 years ago by Jeroen Demeyer

Description: modified (diff)
Summary: Problems with exception handling on OS X with custom GCCProblems with C++ exception handling on OS X with custom GCC

comment:3 Changed 11 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Milestone: sage-5.0sage-duplicate/invalid/wontfix
Resolution: wontfix
Reviewers: Jeroen Demeyer
Status: newclosed

Closing this as wontfix, since gcc-4.6.2 does not have this problem.

Note: See TracTickets for help on using tickets.