Opened 9 years ago

Closed 9 years ago

#12435 closed defect (duplicate)

lcalc does not respect global CXX flag

Reported by: ohanar Owned by: GeorgSWeber
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Leif Leonhardy
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

The lcalc spkg currently does not respect the global CXX flag, we should fix this (for instance for #12426).

I've posted an spkg fixes this (and #12436, #12437) at http://wstein.org/home/ohanar/clang-port/sage-5.0.beta1-src/spkg/standard/lcalc-1.23.p10.spkg. (This is a review spkg in case there are more issues with clang down the road.)

Duplicate of #12681.

Attachments (1)

lcalc-cxx-flag.patch (931 bytes) - added by ohanar 9 years ago.
for review purposes

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by ohanar

  • Description modified (diff)
  • Status changed from new to needs_review

Changed 9 years ago by ohanar

for review purposes

comment:2 Changed 9 years ago by leif

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix

Ooops, didn't see this ticket (as it was not listed on #2999 / #3000).

Since #12681 has meanwhile been merged into Sage 5.0.beta9, we should close this. Sorry.

Unfortunately your changes from #12436 and #12437 will then have to be "rebased" on my spkg.

comment:3 Changed 9 years ago by leif

  • Reviewers set to Leif Leonhardy
  • Status changed from needs_review to positive_review

Positive review w.r.t. that this is now fixed by #12681, so this ticket can be closed.

comment:4 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.