Opened 8 years ago

Closed 5 years ago

#12398 closed defect (fixed)

Sage doesn't install if SAGE_ROOT has a "+" in it (because of R)

Reported by: jhpalmieri Owned by: tbd
Priority: trivial Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: R r-project
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jhpalmieri)

Because of a bug in R's installation, Sage won't install (at least on sage.math and on OS X) if the path name for SAGE_ROOT contains '+'.

I think this is a pretty trivial problem, so perhaps we can wait until it's fixed upstream. I just reported it to the R bug tracking website, and I'll report back when I hear anything interesting.

Change History (11)

comment:1 follow-up: Changed 8 years ago by jdemeyer

John: could you post a link to the exact R bug instead of the bug tracking portal page?

comment:2 in reply to: ↑ 1 Changed 8 years ago by jhpalmieri

  • Description modified (diff)

Replying to jdemeyer:

John: could you post a link to the exact R bug instead of the bug tracking portal page?

Okay, done.

comment:3 Changed 8 years ago by jhpalmieri

  • Report Upstream changed from Reported upstream. Little or no feedback. to Fixed upstream, in a later stable release.

This is now claimed to be fixed, although I can't tell from the link what the fix actually is or when or where it will appear. I've changed the status here to "Fixed upstream, in a later stable release", hoping that this is accurate.

comment:4 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 5 years ago by aapitzsch

  • Status changed from new to needs_info

Can you reproduce this issue with recent R 3.2?

comment:9 Changed 5 years ago by jhpalmieri

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix

Looks like this is now fixed. At least Sage is able to install R if the path name contains '+', on both OS X and linux.

Positive review, won't fix? (Or "works for me" or some other suitable conclusion.)

comment:10 Changed 5 years ago by aapitzsch

  • Status changed from needs_info to positive_review

comment:11 Changed 5 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.