Opened 9 years ago

Closed 9 years ago

#12304 closed defect (fixed)

Singular build failure on OS X 10.4 when directory name is long

Reported by: jdemeyer Owned by: tbd
Priority: critical Milestone: sage-5.0
Component: packages: standard Keywords:
Cc: malb, kcrisman Merged in: sage-5.0.beta0
Authors: Jeroen Demeyer Reviewers: Karl-Dieter Crisman
Report Upstream: Fixed upstream, but not in a stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

When building Sage within a directory with a long name, singular fails to build on OS X 10.4. For example:

$ pwd
/Users/jdemeyer/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-sage-4.8

This problem was discovered by the newly added "moufang" (UGent) buildbot.

This is because of a problem with src/factory/configure and is fixed by generating configure with a more recent autoconf version.

Reported upstream: http://www.singular.uni-kl.de:8002/trac/ticket/399

spkg: http://boxen.math.washington.edu/home/jdemeyer/spkg/singular-3-1-3-3.p4.spkg

Change History (15)

comment:1 Changed 9 years ago by jdemeyer

  • Cc malb kcrisman added
  • Description modified (diff)
  • Report Upstream changed from N/A to Reported upstream. Little or no feedback.
  • Status changed from new to needs_review

comment:2 Changed 9 years ago by jdemeyer

  • Priority changed from major to critical

comment:3 follow-ups: Changed 9 years ago by kcrisman

So do you think this is the problem I had? After all, names with prealpha in them are longer than those with alpha in them...

comment:4 in reply to: ↑ 3 Changed 9 years ago by jdemeyer

Replying to kcrisman:

So do you think this is the problem I had?

The new spkg fixes a problem, but I don't know if this caused your build failure. Just try the new spkg here and let me know whether it works...

comment:5 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by jdemeyer

Replying to kcrisman:

So do you think this is the problem I had?

No, I reproduced your problem. It has nothing to do with Singular, it is caused by #11073. Can you copy the file spkg/bin/testcc.sh to local/bin/testcc.sh and try building again? This file was moved in #11073.

comment:6 Changed 9 years ago by jdemeyer

  • Report Upstream changed from Reported upstream. Little or no feedback. to Fixed upstream, but not in a stable release.

comment:7 in reply to: ↑ 5 Changed 9 years ago by kcrisman

So do you think this is the problem I had?

No, I reproduced your problem. It has nothing to do with Singular, it is caused by #11073. Can you copy the file spkg/bin/testcc.sh to local/bin/testcc.sh and try building again? This file was moved in #11073.

I finally was able to get Xcode for one of my old home computers with similar specs, and building 5.0.beta0 went fine (which has the full #11073, including the cp to local/bin). Still checking on my work computer but no problems in Singular thus far.

comment:8 Changed 9 years ago by kcrisman

I can try to build Sage with a really long directory name if you'd like to test this ticket. How long will it have to be?

comment:9 follow-up: Changed 9 years ago by jdemeyer

It doesn't have to be super-long, try the example in the ticket description.

comment:10 in reply to: ↑ 9 Changed 9 years ago by kcrisman

It doesn't have to be super-long, try the example in the ticket description.

Okay, I'll try this when the load is lower on that computer.


The #11073 definitely was fixed, thanks.

comment:11 Changed 9 years ago by kcrisman

Okay, I have now observed the failure. I've downloaded the new spkg and should know more in about an hour. Actually, more like five minutes since that's where the other one broke, but might as well let it finish :)

comment:12 follow-up: Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman

It works! I will not try this on other platforms, trusting it works to the release manager. I'm certainly not going to try to compare that new conf file to the old one, and I don't understand it in any case.

It seems like the changes in the spkg are not checked in, though. Since that's the case, you might as well fix the typo "spgk-changes" in SPKG.txt.

comment:13 in reply to: ↑ 12 Changed 9 years ago by jdemeyer

Replying to kcrisman:

It works! I will not try this on other platforms, trusting it works to the release manager.

In any case, the release will be tested on the buildbot.

I'm certainly not going to try to compare that new conf file to the old one, and I don't understand it in any case.

Obviously, you shouldn't. Now that upstream made the same change, you can consider the patch as coming from upstream.

It seems like the changes in the spkg are not checked in, though.

Done.

Since that's the case, you might as well fix the typo "spgk-changes" in SPKG.txt.

Done.

comment:14 Changed 9 years ago by kcrisman

  • Status changed from needs_review to positive_review

Looks good.

comment:15 Changed 9 years ago by jdemeyer

  • Merged in set to sage-5.0.beta0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.