Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#12286 closed defect (fixed)

docstring for factorial function mentions unsupported algorithm keyword

Reported by: benjaminfjones Owned by: burcin
Priority: minor Milestone: sage-5.0
Component: symbolics Keywords: factorial function symbolics sd35.5 beginner
Cc: kcrisman Merged in: sage-5.0.beta0
Authors: Peter Story Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The docstring for the global factorial function claims that an optional keyword algorithm can be specified, but currently this raises an error.

sage: factorial(4, algorithm='pari')
...
TypeError: __call__() got an unexpected keyword argument 'algorithm'
sage: factorial(10, algorithm='gmp')
...
TypeError: __call__() got an unexpected keyword argument 'algorithm'

Attachments (1)

trac_12286_algorithmRemoval_nTweak.patch (876 bytes) - added by peter.story 8 years ago.
Fixed line length.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by benjaminfjones

  • Keywords beginner added

comment:2 Changed 8 years ago by burcin

See also #9248.

comment:3 Changed 8 years ago by peter.story

  • Status changed from new to needs_review

I removed all mention of the algorithm argument, and better defined what 'n' value can be provided (with the help of Benjamin Jones).

comment:4 Changed 8 years ago by kcrisman

  • Cc kcrisman added

comment:5 Changed 8 years ago by peter.story

  • Authors set to peter.story, benjaminfjones

comment:6 Changed 8 years ago by peter.story

  • Authors changed from peter.story, benjaminfjones to peter.story

comment:7 Changed 8 years ago by kcrisman

  • Authors changed from peter.story to Peter Story

We put full names :)

comment:8 Changed 8 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_review to needs_work

This probably needs to be formatted so that the line isn't so long. You can do it exactly like the ones you deleted, in terms of the spacing.

Changed 8 years ago by peter.story

Fixed line length.

comment:9 Changed 8 years ago by peter.story

  • Status changed from needs_work to needs_review

comment:10 Changed 8 years ago by kcrisman

Yeah, this hasn't been used since before the Pynac switch. Anyway, looks good!

comment:11 Changed 8 years ago by kcrisman

  • Status changed from needs_review to positive_review

comment:12 Changed 8 years ago by jdemeyer

  • Merged in set to sage-5.0.beta0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:13 Changed 5 years ago by rws

Actually, the cause of the originally reported issue is described and fixed in #17489.

Note: See TracTickets for help on using tickets.