Opened 9 years ago

Closed 9 years ago

#12277 closed defect (duplicate)

Warnings in `plot_slope_field`

Reported by: novoselt Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: jason Merged in:
Authors: Reviewers: Karl-Dieter Crisman, Andrey Novoseltsev
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by novoselt)

Duplicate of #11208

If I do (in Sage 4.7.2 or 4.8.alpha6)

plot_slope_field(1, (1,2), (3,4))

(or anything else that I have tried), then in front of the plot, which looks as expected, I get

Warning: divide by zero encountered in divide
Warning: invalid value encountered in multiply
Warning: invalid value encountered in multiply
Warning: divide by zero encountered in divide
Warning: invalid value encountered in multiply
Warning: invalid value encountered in multiply

My investigation so far shows: this function is a little wrapper for plot_vector_field which sets new defaults for three options. If headlength is set to 0, there are warnings.

A possible workaround is to set it to something small: 0.001 seems to work on the screen. However, since with headaxislength=0 and headlength=0.2 I definitely see "a hair on the end", it does not seem to be satisfactory from a perfectionist point of view (and producing vector formats that may be scaled or printed with high resolution).

Besides, current settings do produce the accurate plot, it just shows warnings that should not be there, and I have no idea how to fix it.

Change History (9)

comment:1 Changed 9 years ago by jason

It seems like I remember that this was fixed in the new matplotlib 1.1.0 release (an spkg is up on trac somewhere).

comment:2 follow-up: Changed 9 years ago by jason

Ah yes, #11915. Do you still see the problem after applying that spkg?

comment:3 in reply to: ↑ 2 Changed 9 years ago by novoselt

Replying to jason:

Ah yes, #11915. Do you still see the problem after applying that spkg?

Yes, the same issue both in 4.7.2 and 4.8.alpha6 with #11915 applied. Are these warnings coming from matplotlib? Also, what would be an appropriate doctest for this bug?

comment:4 Changed 9 years ago by kcrisman

This is a dup of #11208? Probably. See also #2922.

comment:5 Changed 9 years ago by novoselt

  • Description modified (diff)
  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Yes, strange I couldn't find it, I tried to search... My current workaround is that I have redefined plot_slope_field. It is in a way good, since I also had to fix aspect ratio (for 4.7.2) and changed defaults for colour and frame to match the textbook I am using.

comment:6 Changed 9 years ago by novoselt

  • Status changed from needs_review to positive_review

comment:7 Changed 9 years ago by novoselt

Am I supposed to do anything with author/reviewer fields?

comment:8 Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman, Andrey Novoseltsev

One puts the reviewers only to those who realized, it, at least in the usage lately. If I misspelled your name, just fix it.

comment:9 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.