Opened 8 years ago

Closed 8 years ago

#12256 closed defect (duplicate)

if x=var('x') and n is an integer then n.binomial(x) should return binomial(SR(n),x)

Reported by: was Owned by: burcin
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers: Burcin Erocal
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Somebody tried to do

sum(binomial(3, k), k, 0, 3)

and got a weird error, but

sum(binomial(SR(3), k), k, 0, 3)

works. This is because 3.binomial isn't sophisticated enough... or maybe binomial(-, -) isn't either.

This is a duplicate of #9634.

Change History (4)

comment:1 Changed 8 years ago by was

  • Description modified (diff)

comment:2 Changed 8 years ago by burcin

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Reviewers set to Burcin Erocal
  • Status changed from new to needs_review

This is a duplicate of #9634.

comment:3 Changed 8 years ago by burcin

  • Status changed from needs_review to positive_review

comment:4 Changed 8 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.