Opened 9 years ago

Closed 9 years ago

#12252 closed defect (duplicate)

latex(number field) sometimes looks stupid (though is technically correct)

Reported by: was Owned by: davidloeffler
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords:
Cc: Merged in:
Authors: Reviewers: David Loeffler
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by was)

For example,

sage: K = NumberField(x^2 +1, 'i'); K
Number Field in i with defining polynomial x^2 + 1
sage: latex(K)
\Bold{Q}[i]/(i^{2} + 1)

Some might smirk at this. Another worse one:

sage: latex(QuadraticField(-1))
\Bold{Q}[\sqrt{-1}]/(\sqrt{-1}^{2} + 1)

Change History (7)

comment:1 Changed 9 years ago by was

  • Description modified (diff)
  • Summary changed from latex(number field) looks stupid (though is technically correct) to latex(number field) sometimes looks stupid (though is technically correct)

comment:2 Changed 9 years ago by lftabera

I think that this is a duplicate of #12196

comment:3 Changed 9 years ago by davidloeffler

The second one is fixed by #12196. The first one isn't changed, but I don't see what's wrong with the current output, to be honest.

comment:4 Changed 9 years ago by was

David, you are right. This ticket should be closed as a dup.

comment:5 Changed 9 years ago by davidloeffler

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:6 Changed 9 years ago by davidloeffler

  • Status changed from needs_review to positive_review

comment:7 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to David Loeffler
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.