Opened 9 years ago

Closed 8 years ago

#12143 closed defect (duplicate)

PariError when creating a relative number field

Reported by: culler Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords:
Cc: Merged in:
Authors: Reviewers: Marco Streng
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by mstreng)

Please close as duplicate of #252

sage: t = QQ['t'].gen() 
sage: K.<a> = QQ.extension(t^6 - 1/4*t^3 - 1/64)
sage: s = K['s'].gen() 
sage: g = s^4 + 2*a^2*s^2 + a^4 + a
sage: L.<b> = K.extension(g)

fails with PariError?: inconsistent data (12)

The failure occurs in: rings.number_field.number_field_rel.pari_relative_polynomial().polisirreducible()

If, instead, one tries:

sage: L.<b> = K.extension(g, check=False)

it fails with PariError?: (5)

This time it fails in: pari_absolute_base_polynomial().rnfequation(self.pari_relative_polynomial(), 1)

Change History (7)

comment:1 follow-up: Changed 9 years ago by culler

I see now that this is just another example of NumberField? not working with polynomials that are not monic or not integral, which goes back 5 years to #252. So feel free to close the ticket. Unfortunately I don't see any way to work around it in my project. Too bad.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 9 years ago by fwclarke

Replying to culler:

Unfortunately I don't see any way to work around it in my project.

I think the following works:

sage: PQ.<t> = QQ[]
sage: f = t^6 - 1/4*t^3 - 1/64
sage: f = PQ(pari(f).polredabs())
sage: K.<a> = QQ.extension(f)
sage: s = K['s'].gen()
sage: g = s^4 + 2*a^2*s^2 + a^4 + a
sage: L.<b> = K.extension(g)
sage: L
Number Field in b with defining polynomial s^4 + 2*a^2*s^2 + a^4 + a over its base field
sage: K
Number Field in a with defining polynomial t^6 - 2*t^3 - 1

I think this technique could be used to sort out #252. But there are many details to be got right.

comment:3 in reply to: ↑ 2 Changed 9 years ago by culler

Replying to fwclarke:

Thanks! That is very helpful. It is not the whole story, I'm afraid, since I am working in a tower of extensions and the call pari(f) seems to fail if f does not have rational coefficients. Still, it gets things off the ground and gives me a hint about where to look for the rest of the answer.

comment:4 Changed 8 years ago by mstreng

  • Description modified (diff)
  • Status changed from new to needs_review

comment:5 Changed 8 years ago by mstreng

  • Status changed from needs_review to positive_review

comment:6 Changed 8 years ago by mstreng

  • Milestone changed from sage-5.10 to sage-duplicate/invalid/wontfix

comment:7 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Marco Streng
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.