Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#12139 closed defect (fixed)

Disable parallel "make install" in MPIR spkg

Reported by: jdemeyer Owned by: tbd
Priority: blocker Milestone: sage-4.8
Component: packages: standard Keywords:
Cc: jhpalmieri Merged in: sage-4.8.alpha4
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

make -j6  install-data-hook
make[6]: Entering directory `/mnt/usb1/scratch/jdemeyer/merger/sage-4.8.alpha3-remove-base/spkg/build/mpir-2.1.3.p7/src'
make[6]: warning: -jN forced in submake: disabling jobserver mode.
(cd /mnt/usb1/scratch/jdemeyer/merger/sage-4.8.alpha3-remove-base/local/include  && rm -f gmp.h   && cp mpir.h   gmp.h)
cp: cannot stat `mpir.h': No such file or directory
make[6]: *** [install-data-hook] Error 1
make[6]: Leaving directory `/mnt/usb1/scratch/jdemeyer/merger/sage-4.8.alpha3-remove-base/spkg/build/mpir-2.1.3.p7/src'
make[5]: *** [install-data-am] Error 2
make[5]: *** Waiting for unfinished jobs....

New spkg: http://boxen.math.washington.edu/home/jdemeyer/spkg/mpir-2.1.3.p8.spkg

Attachments (1)

mpir-2.1.3.p7-p8.diff (2.5 KB) - added by jdemeyer 10 years ago.
Diff for the mpir spkg, for review only

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 10 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Priority changed from critical to blocker
  • Status changed from new to needs_review
  • Summary changed from Fix parallel building MPIR to Disable parallel "make install" in MPIR spkg

comment:3 Changed 10 years ago by jdemeyer

  • Description modified (diff)

Changed 10 years ago by jdemeyer

Diff for the mpir spkg, for review only

comment:4 Changed 10 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

Looks good.

comment:5 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.8.alpha4
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:6 Changed 10 years ago by leif

Just wondering why you omitted the message given by spkg-install from the description; this is a long-known minor bug and already fixed upstream, "just for us" btw., in a (this-)bug-fix-only release.

It would have been hardly more work to just upgrade to 2.1.4 (or later), thereby finally fixing the bug instead of working around it.

Note: See TracTickets for help on using tickets.