Opened 10 years ago

Closed 10 years ago

#12100 closed defect (invalid)

proof parameter not passed on when factoring polynomials over function fields

Reported by: saraedum Owned by: tbd
Priority: trivial Milestone: sage-duplicate/invalid/wontfix
Component: factorization Keywords: function_fields
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Applying #9054 to sage 4.7.2 factorization does not work anymore in some cases:

sage: k.<x> = FunctionField(GF(5))
sage: R.<y> = k[]
sage: (y^3-x^3+x).factor(proof=False)
NotImplementedError: proof = True factorization not implemented.  Call factor with proof=False.

The problem is that with #10635 the proof parameter is not passed on anymore to _factor_univariate_polynomial(). As a workaround one can of course call k._factor_univariate_polynomial((f,proof=False) directly.

Change History (3)

comment:1 Changed 10 years ago by saraedum

  • Status changed from new to needs_review

I must have been working with an old version of #9054. The behaviour described above does actually not happen with the current version of #9054. This ticket can be closed. Sorry.

comment:2 Changed 10 years ago by saraedum

  • Status changed from needs_review to positive_review

comment:3 Changed 10 years ago by jdemeyer

  • Dependencies #9054 deleted
  • Milestone changed from sage-4.8 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from positive_review to closed

If you want a ticket to be closed, set its milestone to sage-duplicate/invalid/wontfix.

Note: See TracTickets for help on using tickets.