Opened 11 years ago

Closed 11 years ago

#12056 closed defect (fixed)

sage -sdist/-bdist should use the current branch

Reported by: jdemeyer Owned by: leif
Priority: blocker Milestone: sage-4.8
Component: scripts Keywords:
Cc: Merged in: sage-4.8.alpha3
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

It seems that sage -sdist does not work properly with branches: it changes the version of the currently active branch but then packages the sage-main branch. I believe sage -sdist should sdist the currently active branch instead.

Analogously for sage -bdist.

Attachments (1)

12056_sdist.patch (1.8 KB) - added by jdemeyer 11 years ago.
Apply to SCRIPTS repository

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by jdemeyer

  • Description modified (diff)
  • Summary changed from sage -sdist should use the current branch to sage -sdist/-bdist should use the current branch

comment:2 Changed 11 years ago by jdemeyer

  • Status changed from new to needs_review

comment:3 Changed 11 years ago by jdemeyer

  • Status changed from needs_review to needs_work

bdist doesn't work properly.

Changed 11 years ago by jdemeyer

Apply to SCRIPTS repository

comment:4 Changed 11 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:5 Changed 11 years ago by vbraun

  • Status changed from needs_review to positive_review

Looks good!

comment:6 Changed 11 years ago by jdemeyer

  • Reviewers set to Volker Braun

comment:7 Changed 11 years ago by jdemeyer

  • Merged in set to sage-4.8.alpha3
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.