Opened 8 years ago

Closed 7 years ago

#12007 closed defect (duplicate)

creation of extension field of finite field needs more parameter checking

Reported by: mariah Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers: David Roe
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

In sage-4.7.2,

sage: F = GF(2)
sage: P.<x> = PolynomialRing(F)
sage: H.<h> = GF(2^8, name='h', modulus=x^3+x+1) # 2^8 rather than 2^3
sage:
sage: len(set([h^i for i in xrange(10000)]))
21

H is something - but it is not a field!

Fixed by #11784.

Change History (4)

comment:1 Changed 8 years ago by lftabera

This is a duplicate of #11784 that needs review :)

comment:2 Changed 7 years ago by roed

  • Status changed from new to needs_review

comment:3 Changed 7 years ago by roed

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

comment:4 Changed 7 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Reviewers set to David Roe
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.