Opened 9 years ago

Closed 7 years ago

#11992 closed task (duplicate)

Fix gmp type declarations

Reported by: robertwb Owned by: jason
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: misc Keywords:
Cc: fbissey Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

They are currently declared as void*, which will give warnings in the new Cython and allow incorrect C code (e.g. assignments) to be generated.

Attachments (1)

11992-gmp-types.patch (1.3 KB) - added by robertwb 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by robertwb

comment:1 Changed 9 years ago by robertwb

Sage does not compile with this patch, numerous other things need to be fixed up first.

comment:2 Changed 9 years ago by fbissey

  • Cc fbissey added

comment:3 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:7 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #15946.

comment:8 Changed 7 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:9 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.