Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#11971 closed defect (fixed)

get_memory_usage() doctest failure

Reported by: Jeroen Demeyer Owned by: Minh Van Nguyen
Priority: minor Milestone: sage-4.8
Component: doctest coverage Keywords:
Cc: Justin Walker Merged in: sage-4.8.alpha2
Authors: Jeroen Demeyer Reviewers: Justin Walker
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Frédéric Chapoton)

Justin reports on sage-release:

Built from scratch on Mac OS X, 10.6.8 (Dual 6-Core Xeon) w/o problems.  Testing (ptestlong) yielded one failure:
----------------------------------------------------------------------
The temporary doctesting directory
   /Users/justin/.sage/tmp/Zippo.local-33453
was not removed: it is not empty, presumably because doctests
failed or doctesting was interrupted.

----------------------------------------------------------------------

The following tests failed:

sage -t  -long -force_lib devel/sage/sage/misc/getusage.py # 1 doctests failed
----------------------------------------------------------------------
**********************************************************************
File "/Users/Sage/sage-4.7.2.rc1/devel/sage-main/sage/misc/getusage.py", line 93
:
    sage: get_memory_usage(t)          # amount of memory more than when we defined t.
Expected:
    0.0
Got:
    0.25
**********************************************************************

Attachments (1)

11971_getrusage.patch (2.4 KB) - added by Jeroen Demeyer 11 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Leif Leonhardy

EXAMPLES: should now be EXAMPLES:: (i.e., with a double-colon).

The program names (prstat and top etc.) should be typeset in monospaced / typewriter font, i.e. for example ``prstat`` instead of 'prstat'.

Changed 11 years ago by Jeroen Demeyer

Attachment: 11971_getrusage.patch added

comment:2 Changed 11 years ago by Leif Leonhardy

Ok, new patch looks good (although I'd also use ``t`` instead of `t`, since it is a Python identifier rather than some mathematical variable or symbol), but Justin should test it and give it positive review.

comment:3 Changed 11 years ago by Leif Leonhardy

P.S.: FWIW, applies to rc0 and passes tests on Ubuntu 10.04.3 x86_64.

comment:4 Changed 11 years ago by Justin Walker

Summary: get_memory_usage() doctest failureget_memory_usage() doctest failure (positive_review)

I can't now reproduce the doctest failure; maybe cosmic rays are to blame.

In any case, the doctests all pass with the patch applied; the changes seem reasonable.

comment:5 Changed 11 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Priority: blockerminor
Reviewers: Justin Walker
Status: newneeds_review

comment:6 Changed 11 years ago by Jeroen Demeyer

Status: needs_reviewpositive_review
Summary: get_memory_usage() doctest failure (positive_review)get_memory_usage() doctest failure

comment:7 Changed 11 years ago by Jeroen Demeyer

Merged in: sage-4.8.alpha2
Resolution: fixed
Status: positive_reviewclosed

comment:8 Changed 7 years ago by Frédéric Chapoton

Description: modified (diff)
Note: See TracTickets for help on using tickets.