Opened 10 years ago

Closed 6 years ago

#11922 closed defect (duplicate)

extension of ZZ gives wrong generator

Reported by: dkrenn Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: extension, ZZ, integers, generator
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Generating an extension in the way below gives back the wrong generator.

sage: Z.<z> = ZZ.extension(x^2+1); Z
Order in Number Field in z with defining polynomial x^2 + 1
sage: z
1

The output should be

sage: z
z

as, for example, in the case of an extension of QQ, which works correctly.

Change History (8)

comment:1 Changed 10 years ago by davidloeffler

Yup, this is annoying. The reason for this is that the X.<y> syntax defines y to be the first element of X.gens(), but gens for number field orders returns *module* generators, not *ring* generators (which don't always exist for general orders).

It would certainly be nice to fix this, but it's not clear to me what the best solution is.

comment:2 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:6 Changed 6 years ago by jdemeyer

  • Authors Daniel Krenn deleted
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #15348.

comment:7 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:8 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.