Opened 10 years ago

Closed 9 years ago

#11909 closed defect (duplicate)

Merging fixes for PolyBoRi 0.7.1 into 0.8 spkg

Reported by: AlexanderDreyer Owned by: AlexanderDreyer
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: leif Merged in:
Authors: Reviewers: Alexander Dreyer, Leif Leonhardy
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: #12750 #12655 Stopgaps:

Status badges

Change History (15)

comment:1 Changed 10 years ago by AlexanderDreyer

  • Description modified (diff)
  • Status changed from new to needs_review

The new spkg is here: http://boxen.math.washington.edu/home/dreyer/spkg/polybori-0.8.0.p2.spkg It also utilizes M4RI_CFLAGS when available.

comment:2 Changed 10 years ago by AlexanderDreyer

  • Description modified (diff)

comment:3 Changed 10 years ago by AlexanderDreyer

Due to change in the 0.7.1 spkg, I had to rebundle another spkg (at the same place above).

comment:4 Changed 10 years ago by AlexanderDreyer

The new spkg builds, installs and passes all tests on SuSE Enterprise 11 (with SP1) on amd64 and OS X 10.5 ppc.

comment:5 Changed 9 years ago by AlexanderDreyer

  • Description modified (diff)

maybe need to merge with the new p2.spkg

comment:6 follow-up: Changed 9 years ago by jdemeyer

  • Status changed from needs_review to needs_info

How is this related to #12750 and #12655?

comment:7 in reply to: ↑ 6 ; follow-up: Changed 9 years ago by leif

  • Dependencies changed from #11575 #11906 to #11575 #11750
  • Status changed from needs_info to needs_review
  • Work issues set to Rebase the spkg on the p2 from #12750.

Replying to jdemeyer:

How is this related to #12750 and #12655?

The spkg here should get rebased on that of #12750, to a p3.

If #12655 (currently needing work) gets merged before this one, this ticket can be closed, as upgrading to 0.8.1 would also fix the issue, if I'm not completely wrong.

comment:8 Changed 9 years ago by leif

  • Authors changed from AlexanderDreyer to Alexander Dreyer
  • Dependencies changed from #11575 #11750 to #12750
  • Status changed from needs_review to needs_work

comment:9 in reply to: ↑ 7 ; follow-up: Changed 9 years ago by leif

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to needs_info

Replying to leif:

If #12655 (currently needing work) gets merged before this one, this ticket can be closed, as upgrading to 0.8.1 would also fix the issue, if I'm not completely wrong.

So can we close this ticket now?

comment:10 in reply to: ↑ 9 Changed 9 years ago by AlexanderDreyer

Replying to leif:

So can we close this ticket now?

Yes, it's obsolete now.

comment:11 Changed 9 years ago by leif

  • Authors Alexander Dreyer deleted
  • Reviewers set to Alexander Dreyer, Leif Leonhardy
  • Status changed from needs_info to needs_review

comment:12 Changed 9 years ago by leif

  • Status changed from needs_review to positive_review

comment:13 Changed 9 years ago by leif

  • Dependencies changed from #12750 to #12750 #12655

comment:14 Changed 9 years ago by leif

  • Work issues Rebase the spkg on the p2 from #12750. deleted

comment:15 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.