Opened 10 years ago

Closed 10 years ago

#11825 closed defect (fixed)

Sage crashes executing pari.setrand(0)

Reported by: jdemeyer Owned by: was
Priority: critical Milestone: sage-4.7.2
Component: interfaces Keywords:
Cc: Merged in: sage-4.7.2.alpha4
Authors: Jeroen Demeyer Reviewers: John Cremona
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

sage-4.7.2.alpha2 on an Intel 64-bit Gentoo Linux system:

sage: pari.setrand(0)
  ***   incorrect type in setrand.
  ***   Error in the PARI system. End of program.

The error message can vary, but it always causes Sage to quit/crash.

Attachments (1)

11825.patch (1.7 KB) - added by jdemeyer 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jdemeyer

comment:1 Changed 10 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Status changed from new to needs_review

comment:2 Changed 10 years ago by jdemeyer

  • Description modified (diff)

comment:3 follow-up: Changed 10 years ago by cremona

  • Status changed from needs_review to positive_review

Patch looks good and applies fine to 4.7.2.alpha2, tests pass -- the horrible crash no longer occurs.

I did *not* test this with 4.7.2.alpha2+#11130.

comment:4 in reply to: ↑ 3 Changed 10 years ago by cremona

Replying to cremona:

Patch looks good and applies fine to 4.7.2.alpha2, tests pass -- the horrible crash no longer occurs.

I did *not* test this with 4.7.2.alpha2+#11130.

But now I have, and confirm that this still works with 4.7.2.alpha2+#11130.

comment:5 Changed 10 years ago by davidloeffler

  • Reviewers set to John Cremona

comment:6 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.7.2.alpha4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.