Opened 10 years ago

Closed 10 years ago

#11788 closed defect (duplicate)

Symmetrica fails to build under stricter gcc-4.6.x link rules

Reported by: john.hoebing Owned by: GeorgSWeber
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: gcc-4.6, linker, symmetrica
Cc: Merged in:
Authors: Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #10719 Stopgaps:

Status badges

Description

Singular and symmetric are known to break because of misplaced libraries in link commands.  Symmetrica can be fixed by moving a '-lm' in one Makefile.  I describe the bug to the maintainer of symmetric in the following email; he has already replied and I confirmed that we would like him to fix the problem in the downloadable Symmetrica from the website.  Hopefully the official Symmetrica will contain this fix soon and we can incorporate the latest package in upcoming the upcoming Sage release.  Here's the email:

Hi,I work on the open source Sage package, and Sage fails tobuild on the latest Ubuntu 11.10 beta with the defaultcompiler gcc-4.6.1.  The problem is that Sage uses Symmetrica, and the latestgcc-4.6.1 enforces linker semantics that requires the '-lm'flag to come _after_ the .o files.   In Symmetrica, the '-lm'flag precedes the .o files, leading to the following build error:gcc -O1 -fPIC -g -DFAST -DALLTRUE -lm test.c bar.o bi.o boe.o bruch.o classical.o de.o di.o ff.o galois.o ga.o gra.o hash.o hiccup.o io.o ko.o list.o lo.o ma.o mee.o mem.o mes.o mhe.o mhh.o mhm.o mhp.o mhs.o mmm.o mms.o mod_dg_sbd.o mo.o mpp.o mps.o mse.o msh.o msm.o mss.o muir.o na.o nb.o nc.o nu.o part.o pee.o peh.o pem.o perm.o pes.o phe.o phh.o phm.o phs.o plet.o pme.o pmh.o poly.o ppe.o pph.o ppm.o ppp.o pps.o pr.o pse.o psh.o psm.o pss.o rest.o rh.o sab.o sb.o sc.o sr.o ta.o teh.o tem.o tep.o tes.o the.o thm.o thp.o ths.o tme.o tmh.o tmp.o tms.o tpe.o tph.o tpm.o tps.o tse.o tsh.o tsm.o tsp.o vc.o zo.o zykelind.o zyk.o -o test nb.o: In function convert_radical_cyclo':/home/jlh/wrk/sage-4.7.1/spkg/build/symmetrica-2.0.p5/src/!nb.c:4087: undefined reference t cos'/home/jlh/wrk/sage-4.7.1/spkg/build/symmetrica-2.0.p5/src/nb.c:4087: undefined reference t cos'/home/jlh/wrk/sage-4.7.1/spkg/build/symmetrica-2.0.p5/src/!nb.c:4087: undefined reference t cos'/home/jlh/wrk/sage-4.7.1/spkg/build/symmetrica-2.0.p5/src/nb.c:4087: undefined reference t `cos'collect2: ld returned 1 exit statusWould it be possible for you to fix this problem, for instance by simplymoving the above '-lm' to after the 'zyk.o'?  It would allow Symmetricato be built on the current Ubuntu 11.10 and later releases, and wouldallow us to use Symmetrica in Sage on Ubuntu 11.10.Thanks,John Hoebing

Change History (4)

comment:1 Changed 10 years ago by leif

  • Component changed from build to packages
  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to defect

This is a duplicate of #10719, see also this sage-devel thread.

By the way, this is unrelated to the compiler, it's the linker.

comment:2 Changed 10 years ago by leif

For Singular, see #11769.

comment:3 Changed 10 years ago by vbraun

  • Dependencies set to #10719
  • Status changed from needs_review to positive_review

Fixed by #10719.

comment:4 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Volker Braun
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.