Opened 10 years ago

Closed 9 years ago

#11694 closed defect (duplicate)

Unlabelled edges are doubled when creating multiedge graph

Reported by: iandrus Owned by: iandrus
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords:
Cc: Merged in:
Authors: Reviewers: Ivan Andrus, Nathann Cohen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

When creating a graph from a list of edges, if the edges are not labelled they get doubled when multiedges are allowed. It works fine if they are labelled.

sage: g=Graph([[1,2],[1,2,],[2,3]])
sage: g.num_edges()
6
sage: g=Graph([[1,2,'a'],[1,2,'b'],[2,3,'c']])
sage: g.num_edges()
3

See #11693.

Change History (8)

comment:1 Changed 10 years ago by iandrus

  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix

This is actually a duplicate of #11693, but I didn't realize that.

comment:2 Changed 10 years ago by iandrus

  • Status changed from new to needs_review

comment:3 Changed 10 years ago by ncohen

  • Status changed from needs_review to needs_info

This ticket definitely isn't needing a review as there is no patch attached. Should it be removed as a duplicated as was done before ?

Nathann

comment:4 follow-up: Changed 10 years ago by iandrus

I think I read somewhere that I should set milestone as duplicate and then make it needs_review so that someone else can actually close it. It should be closed with extreme prejudice.

comment:5 in reply to: ↑ 4 Changed 10 years ago by ncohen

I think I read somewhere that I should set milestone as duplicate and then make it needs_review so that someone else can actually close it. It should be closed with extreme prejudice.

Oh right, right, closing tickets is the release manager's exclusive right, but if this one is to be closed the best may be to send him an email :-)

Nathann

comment:6 Changed 9 years ago by iandrus

  • Status changed from needs_info to needs_review

I sent jdemeyer an email.

comment:7 Changed 9 years ago by jdemeyer

  • Reviewers set to Ivan Andrus, Nathann Cohen
  • Status changed from needs_review to positive_review

comment:8 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.