Opened 8 years ago

Closed 8 years ago

#11656 closed defect (duplicate)

Imaginary part of symbolic variable disappears in simplify_full()

Reported by: jan Owned by: burcin
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords: maxima
Cc: Merged in:
Authors: Reviewers: Burcin Erocal
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jan)

var('c', domain='complex')
var('x', domain='real')
C = c * exp(-x^2)
print (C)
    c*e^(-x^2)

print (C.imag())
    e^(-x^2)*imag_part(c)

print (C.imag().simplify_full()) 
    0

Related to two-year old bug #6862. It seems, variables declared as 'complex', are assumed real in maxima. This is fixed by using sage's assume command

assume(c, 'complex')
print (C.imag().simplify_full()) 

gives the correct result.

demonstration notebook: http://demo.sagenb.org/home/pub/178/

Change History (4)

comment:1 Changed 8 years ago by jan

  • Description modified (diff)
  • Keywords maxima added

comment:2 Changed 8 years ago by burcin

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

As stated in the description, this is a duplicate of #6862.

comment:3 Changed 8 years ago by burcin

  • Reviewers set to Burcin Erocal
  • Status changed from needs_review to positive_review

comment:4 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.