Changes between Version 9 and Version 11 of Ticket #11616


Ignore:
Timestamp:
11/21/11 17:32:54 (10 years ago)
Author:
jdemeyer
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #11616

    • Property Status changed from needs_review to needs_work
    • Property Dependencies changed from #8664 #5847 to
    • Property Work issues changed from to Rebase the spkg(s) on the MPIR 2.1.3.p7 spkg from #11964
  • Ticket #11616 – Description

    v9 v11  
    1111You may want to give both of them a try, although the former is just intended as a "fallback" spkg in case problems introduced in the latter should arise.
    1212
    13 '''Note:''' On '''64-bit''' processors running '''32-bit''' operating systems, one currently has to set `ABI=32`, otherwise the build will fail. This will be fixed in newer versions of the spkgs.
     13'''Note:''' On '''64-bit''' processors running '''32-bit''' operating systems, one currently has to set `ABI=32`, otherwise the build will fail. This is already fixed in #11964.
    1414
    1515[[BR]]
     
    1919[[BR]]
    2020
    21 For instructions on how to install / test the spkgs see also #8664,
    22 although '''the necessary patch and the required GMP-ECM 6.3 spkg from #5847 are now already merged into Sage 4.7.2.alpha3'''; i.e., it is meanwhile sufficient to just
     21For instructions on how to install / test the spkgs see also #8664.  It is sufficient to just
    2322
    2423 * copy the spkg into `$SAGE_ROOT/spkg/standard/`, then
     
    3029}}}
    3130   (or omit `build` to also rebuild the documentation in the same `make` run).
    32 
    33 The test suite of our "current" FLINT 1.5.0 spkg won't build with any of the MPIR 2.x spkgs, so don't use `SAGE_CHECK=yes` when installing it. This will be addressed on #9858, by providing a FLINT 1.5.2 (or 1.6) spkg.
    3431
    3532To run just MPIR's test suite, you can reinstall the spkg with `SAGE_CHECK=yes`: