Opened 13 years ago

Closed 13 years ago

#1160 closed defect (fixed)

[witch patch] *major* bug in using the sage notebook as a maxima notebook

Reported by: was Owned by: was
Priority: critical Milestone: sage-2.8.15
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On Nov 12, 2007 10:20 PM, Moreira <fjm@fc.up.pt> wrote:
> After changing system to Maxima in a worksheet, evaluations of cells
> do not appear. If I write "3+1" in a cell and press SHIFT+ENTER the
> green bar remains. If I interrupt the computation (option in drop down
> menus) then,  the result appears immediately after I press the ok
> button in the  alert message saying "Unable to immediately interrupt
> calculation"
> 
> The same happens if SAGE is chosen as the active system and I begin
> the cell with %maxima.
> 
> However,  writing "maxima(3+1)" the result  appears as expected.
> 
> This happens to me running a vmware image of sage on windows XP and
> accessing SAGE notebook with firefox 2.09. I also tried the notebook
> interface at
> https://sage.math.washington.edu:8103/
> and I obtained the same "behaviour".
> 
> If I  choose other systems (like sh, html,gp)  everything works fine..
> 
> Is anybody experiencing this kind of  behaviour or is only a bug with
> me?!

Yes, I see exactly the same bug.   This is a rather serious bug actually,
and I'm really glad you reported it!  

Attachments (3)

trac-1160.patch (11.6 KB) - added by was 13 years ago.
trac1160-fix.patch (1.1 KB) - added by was 13 years ago.
trac1160-maxima-fix.patch (874 bytes) - added by was 13 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by was

  • Status changed from new to assigned

comment:2 Changed 13 years ago by was

OK, a lead -- this is caused by line 254 of server/support.py, which calls

   maxima.chdir(...)

which hangs.

Changed 13 years ago by was

comment:3 Changed 13 years ago by mhansen

  • Summary changed from *major* bug in using the sage notebook as a maxima notebook to [witch patch] *major* bug in using the sage notebook as a maxima notebook

comment:4 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in 2.8.15.alpha2.

Changed 13 years ago by was

Changed 13 years ago by was

comment:5 Changed 13 years ago by was

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from reopened to closed

Merged trac1160-maxima-fix.patch in 2.8.15.rc0.

Note: See TracTickets for help on using tickets.