Opened 11 years ago

Last modified 11 years ago

#11574 closed enhancement

update M4RI to newest upstream release — at Version 8

Reported by: malb Owned by: tbd
Priority: critical Milestone: sage-4.7.2
Component: packages: standard Keywords: sd32
Cc: strogdon, leif, AlexanderDreyer Merged in:
Authors: Martin Albrecht Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #11261 Stopgaps:

Status badges

Change History (8)

comment:1 Changed 11 years ago by malb

  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 11 years ago by malb

  • Dependencies set to #11261

comment:3 Changed 11 years ago by kcrisman

I'm a little confused. The spkgs here and at #9562 are both libm4ri, and seem to be numbered backwards (the "earlier" one in the dependency is from 2011).

comment:4 Changed 11 years ago by kcrisman

Okay, I think I figured it out. Sorry for the noise.

comment:5 Changed 11 years ago by kcrisman

I don't know what I did wrong, but I still get the problem with the Symbol not found: _m4ri_swap_bits while trying to start, even after this patch. I may have done something wrong, but at any rate I can't spend more time on this now, sorry.

comment:6 Changed 11 years ago by malb

  • Authors set to Martin Albrecht
  • Description modified (diff)

comment:7 Changed 11 years ago by malb

For the record, I tried spkg + patch on t2 and doctests pass.

comment:8 Changed 11 years ago by malb

  • Description modified (diff)
Note: See TracTickets for help on using tickets.