Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#11519 closed defect (duplicate)

Singular hiccups when identifying its version

Reported by: kedlaya Owned by: malb
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords:
Cc: burcin Merged in:
Authors: Kiran Kedlaya Reviewers: Simon King
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

Example from Sage 4.7. Note that this only happens on the first call during a session; subsequent calls return correctly.

sage: singular.version()
---------------------------------------------------------------------------
RuntimeError                              Traceback (most recent call last)

/home/kedlaya/<ipython console> in <module>()

/home/kedlaya/sage-complete/local/lib/python2.6/site-packages/sage/interfaces/singular.pyc in version(self)
   1033         EXAMPLES:
   1034         """
-> 1035         return singular_version()
   1036 
   1037     def _function_class(self):

/home/kedlaya/sage-complete/local/lib/python2.6/site-packages/sage/interfaces/singular.pyc in singular_version()
   1931     EXAMPLES:
   1932     """
-> 1933     return singular.eval('system("--version");')
   1934 
   1935 

/home/kedlaya/sage-complete/local/lib/python2.6/site-packages/sage/interfaces/singular.pyc in eval(self, x, allow_semicolon, strip, **kwds)
    548 
    549         if s.find("error") != -1 or s.find("Segment fault") != -1:
--> 550             raise RuntimeError, 'Singular error:\n%s'%s
    551 
    552         if get_verbose() > 0:

RuntimeError: Singular error:
   ? cannot open `help.cnf`
Singular for x86_64-Linux version 3-1-1 (3114-2011052318)  May 23 2011 18:59:10
with
factory(@(#) factoryVersion = 3.1.1),libfac(3.1.1,Feb 2010),
GMP(4.2),NTL(5.4.2),64bit,static readline,Plural,DBM,
dynamic modules,dynamic p_Procs,OM_CHECK=0,OM_TRACK=0,random=1308341733
CC= gcc -O2 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H,
CXX= g++ -O2 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H (4.4.3)
argv[0]   :Singular-3-1-1
SearchPath:/home/kedlaya/sage-complete/local/share/singular:/home/kedlaya/sage-complete/local/LIB
Singular  :/home/kedlaya/sage-complete/local/bin/Singular
BinDir    :/home/kedlaya/sage-complete/local/bin
RootDir   :/home/kedlaya/sage-complete/local
DefaultDir:
InfoFile  :
IdxFile   :
HtmlDir   :
ManualUrl :http://www.singular.uni-kl.de/Manual/3-1-1
ExDir     :
Path      :/home/kedlaya/sage-complete/local/bin:/home/kedlaya/sage-complete:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
EmacsDir  :
Available HelpBrowsers:dummy, emacs, 
Current HelpBrowser:dummy 
   ? error occurred in or before STDIN line 25: `system("--version");`

Change History (8)

comment:1 Changed 10 years ago by leif

  • Status changed from new to needs_info

Is this something which has to be fixed in our Singular spkg?

(The file help.cnf apparently does not get installed, i.e. I couldn't find it in my Sage 4.7.1.rc0 installation, which comes with singular-3-1-1-4.p9.)

comment:2 follow-up: Changed 10 years ago by leif

Copying src/Singular/LIB/help.cnf to $SAGE_ROOT/local/share/singular fixes this.

Don't know yet if that's a Sage or an upstream issue; anyway, we could "manually" copy the file in Singular's spkg-install.

Though I wonder if the output of singular.version() is desirable in its current form:

sage: singular.version()
'Singular for x86_64-Linux version 3-1-1 (3114-2011072201)  Jul 22 2011 01:23:32\nwith\n\tfactory(@(#) factoryVersion = 3.1.1),libfac(3.1.1,Feb 2010),\n\tGMP(5.0),NTL(5.5.2),64bit,static readline,Plural,DBM,\n\tdynamic modules,dynamic p_Procs,OM_CHECK=0,OM_TRACK=0,random=1312660336\n\tCC= gcc-4.5.1 -march=native -O3 -fno-strict-aliasing -fomit-frame-pointer -DHONORS_CFLAGS -O2 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H,\n\tCXX= g++-4.5.1 -march=native -O3 -fno-strict-aliasing -fomit-frame-pointer -DHONORS_CXXFLAGS -O2 -g -fPIC -pipe -DNDEBUG -DOM_NDEBUG -Dx86_64_Linux -DHAVE_CONFIG_H (4.5.1)\nargv[0]   :\tSingular-3-1-1\nSearchPath:\t/tmp/Sage/sage-4.7.1.rc0-8664/local/share/singular:/tmp/Sage/sage-4.7.1.rc0-8664/local/LIB\nSingular  :\t/tmp/Sage/sage-4.7.1.rc0-8664/local/bin/Singular\nBinDir    :\t/tmp/Sage/sage-4.7.1.rc0-8664/local/bin\nRootDir   :\t/tmp/Sage/sage-4.7.1.rc0-8664/local\nDefaultDir:\t/tmp/Sage/sage-4.7.1.rc0-8664/local\nInfoFile  :\t\nIdxFile   :\t\nHtmlDir   :\t\nManualUrl :\thttp://www.singular.uni-kl.de/Manual/3-1-1\nExDir     :\t\nPath      :\t/tmp/Sage/sage-4.7.1.rc0-8664/local/bin:/tmp/Sage/sage-4.7.1.rc0-8664:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games\nEmacsDir  :\t\nAvailable HelpBrowsers: dummy, emacs, \nCurrent HelpBrowser: dummy '

Maybe there should be some singular.version_string() (giving the output above) or singular.version(full=False) to give some reasonably short string one would perhaps expect.

comment:3 in reply to: ↑ 2 Changed 10 years ago by SimonKing

Replying to leif:

Though I wonder if the output of singular.version() is desirable in its current form: ... Maybe there should be some singular.version_string() (giving the output above) or singular.version(full=False) to give some reasonably short string one would perhaps expect.

I had complained about that at least twice in the past years. I don't remember whether I had created a ticket for it, but I do remember that people on sage-devel didn't care about that problem.

comment:4 Changed 10 years ago by SimonKing

  • Status changed from needs_info to needs_review

comment:5 follow-up: Changed 10 years ago by SimonKing

  • Reviewers set to Simon King
  • Status changed from needs_review to positive_review

The ticket is a duplicate of #5994. I'd be very glad if the old ticket could be revived.

The old ticket already has a patch attached to it (but is "needs info" since more than a year).

If I remember correctly, the procedure is that I give a positive review, the review being "is duplicate", and then the release manager (not I) resolves the ticket accordingly. Right?

comment:6 Changed 10 years ago by leif

  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix

comment:7 in reply to: ↑ 5 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed

Replying to SimonKing:

the procedure is that I give a positive review, the review being "is duplicate", and then the release manager (not I) resolves the ticket accordingly. Right?

And set the milestone to "sage-duplicate/invalid/wontfix" (which leif did for you).

comment:8 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.