Opened 10 years ago

Closed 9 years ago

#11502 closed defect (worksforme)

Maxima fails to build on Cygwin 1.7.3 on XP

Reported by: kcrisman Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: mhansen, dimpase, was Merged in:
Authors: Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This is NOT the same as #11260, as far as I can tell.

test -d binary-ecl || mkdir binary-ecl
ecl -norc -eval '(progn (load "../lisp-utils/defsystem.lisp") (funcall (intern (symbol-name :operate-on-system) :mk) "maxima" :compile :verbose t) (build-maxima-lib))' -eval '(ext:quit)'
;;; Loading */home/.../build/maxima-5.23.p2.p0/src/src/../lisp-utils/defsystem.lisp"
An error occurred during initialization:
Filesystem error with pathname #P"SYS:CMP.NEWEST".
Either
 1) the file does not exist, or
 2) we are not allow to access the file, or
 3) the pathname points to a broken symbolic link.

and then the build quits.

Change History (15)

comment:1 follow-up: Changed 10 years ago by kcrisman

A similar bug was reported at one point on #6517, though it seems to have been resolved without that occurring again.

A very similar problem was reported at this Maxima list thread, and it was resolved by updating defsystem.lisp. We have defsystem 3.4 interim 3 in our current spkg.

A similar, but probably not that closely related, problem is also reported here, where it seems to be related to mismatched versions of something as well.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 10 years ago by kcrisman

A very similar problem was reported at this Maxima list thread, and it was resolved by updating defsystem.lisp. We have defsystem 3.4 interim 3 in our current spkg.

Interestingly, that is exactly the version that is problematic in the thread. But nothing in the code seems obvious with respect to this message.

comment:3 Changed 10 years ago by kcrisman

See also this Maxima bug report and a post to the ECL list.

comment:4 Changed 10 years ago by kcrisman

Here is the ECL list thread.

comment:5 in reply to: ↑ 2 Changed 10 years ago by kcrisman

Replying to kcrisman:

A very similar problem was reported at this Maxima list thread, and it was resolved by updating defsystem.lisp. We have defsystem 3.4 interim 3 in our current spkg.

Interestingly, that is exactly the version that is problematic in the thread. But nothing in the code seems obvious with respect to this message.

The bug report for that report (here), by the way, was closed after no one followed up on it and Maxima had upgrade a fair amount in the meantime. But it's not clear that particular issue was resolved.

Also, it's very hard to find defsystem.lisp. Apparently it's still being developed, but it's very hard to find out where...

comment:6 Changed 10 years ago by kcrisman

Weirdly, I also now have a successful build of Maxima on Cygwin on the same XP machine. It even works from ./sage -maxima!

This is not a positive review or anything; probably the error once in a while doesn't happen. Just reporting.

comment:7 Changed 10 years ago by kcrisman

  • Summary changed from Maxima fails to build on Cygwin on XP to Maxima fails to build on Cygwin 1.7.3 on XP

This once again happened (the correct building with no problems).

Incidentally, all of this is with Cygwin 1.7.3.

comment:8 Changed 10 years ago by kcrisman

Once again correctly built with no intervention on this same virtual machine.

comment:9 follow-up: Changed 10 years ago by kcrisman

  • Cc dimpase added; pasechnik removed

Although #11260 seems to be solved due to #11884, this ticket should remain open until we verify that that fix also took care of it on XP.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 10 years ago by dimpase

  • Status changed from new to needs_info

Replying to kcrisman:

Although #11260 seems to be solved due to #11884, this ticket should remain open until we verify that that fix also took care of it on XP.

if this cannot be reproduced on XP with a recent Cygwin (1.7.9-1 or better), we should close this ticket.

comment:11 in reply to: ↑ 10 ; follow-ups: Changed 10 years ago by kcrisman

Replying to dimpase:

Replying to kcrisman:

Although #11260 seems to be solved due to #11884, this ticket should remain open until we verify that that fix also took care of it on XP.

if this cannot be reproduced on XP with a recent Cygwin (1.7.9-1 or better), we should close this ticket.

Well, I first have to get a working Cygwin on XP again, which will take at least another week. Let's say if I don't by the new year, we close the ticket.

Mike, do you think you could start a Sage build from scratch with the new (Lion, #11884) Maxima package on the XP image you have access to and see what happens?

comment:12 in reply to: ↑ 11 Changed 10 years ago by kcrisman

  • Milestone changed from sage-4.8 to sage-duplicate/invalid/wontfix
  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_info to needs_review

Replying to kcrisman:

Replying to dimpase:

Replying to kcrisman:

Although #11260 seems to be solved due to #11884, this ticket should remain open until we verify that that fix also took care of it on XP.

if this cannot be reproduced on XP with a recent Cygwin (1.7.9-1 or better), we should close this ticket.

Well, I first have to get a working Cygwin on XP again, which will take at least another week. Let's say if I don't by the new year, we close the ticket.

With sage-4.7.2 and the newest Cygwin and the new Maxima and ECL packages for Lion, I didn't have problems getting this to work.

User 1@GC02635 /home/SageUser/sage-4.7.2
$ ./sage -maxima
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/sb-bsd-sockets.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/sockets.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/defsystem.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/cmp.fas"
Maxima 5.23.2 http://maxima.sourceforge.net
using Lisp ECL 11.1.1
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
(%i1) 2+2;
(%o1)                                  4

I think we'll have to close this as invalid - we can always open a new ticket some other time if it does turn out to happen, and if we actually need things.

comment:13 in reply to: ↑ 11 Changed 10 years ago by kcrisman

Replying to kcrisman:

Replying to dimpase:

Replying to kcrisman:

Although #11260 seems to be solved due to #11884, this ticket should remain open until we verify that that fix also took care of it on XP.

if this cannot be reproduced on XP with a recent Cygwin (1.7.9-1 or better), we should close this ticket.

Well, I first have to get a working Cygwin on XP again, which will take at least another week. Let's say if I don't by the new year, we close the ticket.

I didn't have any problems with this on Sage 4.7.2 with the latest Maxima and ECL spkgs.

User 1@GC02635 /home/SageUser/sage-4.7.2
$ ./sage -maxima
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/sb-bsd-sockets.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/sockets.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/defsystem.fas"
;;; Loading #P"/home/SageUser/sage-4.7.2/local/lib/ecl/cmp.fas"
Maxima 5.23.2 http://maxima.sourceforge.net
using Lisp ECL 11.1.1
Distributed under the GNU Public License. See the file COPYING.
Dedicated to the memory of William Schelter.
The function bug_report() provides bug reporting information.
(%i1) 2+2;
(%o1)                                  4

I think this will have to go into sage-invalid for now. We can open another ticket if we really want to some other time, but apparently that problem was a once-off.

comment:14 Changed 10 years ago by kcrisman

  • Status changed from needs_review to positive_review

comment:15 Changed 9 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.