Opened 11 years ago

Closed 11 years ago

#11497 closed defect (worksforme)

Twisted won't build on Cygwin - sometimes

Reported by: Karl-Dieter Crisman Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: Mike Hansen, Dima Pasechnik, William Stein Merged in:
Authors: Reviewers: Reg Burgess, Karl-Dieter Crisman, Dmitrii Pasechnik
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Karl-Dieter Crisman)

Here's a new one: Cygwin fails on Twisted. Note that this has been observed once, on an XP virtual machine. Not on all XP instances, weirdly.

The error looks like errors linking _pmap_set and _pmap_unset.


Spkg at http://sage.math.washington.edu/home/kcrisman/twisted-9.0.p3.spkg

Attachments (1)

trac_11497.diff (3.2 KB) - added by Karl-Dieter Crisman 11 years ago.
For reference only

Download all attachments as: .zip

Change History (21)

comment:1 Changed 11 years ago by Karl-Dieter Crisman

Cc: pasechnik William Stein added
Description: modified (diff)

The internet (e.g. this patch) says that the problem is in twisted/runner/topfiles/setup.py.

The fix is to add the rpc library like in the original fix to that Twisted ticket.

comment:2 Changed 11 years ago by Karl-Dieter Crisman

Cc: Dima Pasechnik added; pasechnik removed

comment:3 Changed 11 years ago by Karl-Dieter Crisman

See also the twisted upgrade ticket - #8741.

comment:4 Changed 11 years ago by Karl-Dieter Crisman

Authors: Karl-Dieter Crisman, Mike Hansen
Status: newneeds_review

comment:5 Changed 11 years ago by Karl-Dieter Crisman

Status: needs_reviewneeds_work

I must have messed something up in the syntax - I forgot a comma. Don't try this yet.

comment:6 Changed 11 years ago by Karl-Dieter Crisman

Okay, hopefully this fixed it. Sorry not to have posted a patch yet - no time now. Same location.

comment:7 Changed 11 years ago by Karl-Dieter Crisman

Description: modified (diff)
Status: needs_workneeds_review

Okay, this is now correct - I fixed the comma, and it worked.

Let's say this ticket is just for XP, for now, since Win7 seems to have so many other troubles. Hopefully that will make it easier to review.

comment:8 Changed 11 years ago by Karl-Dieter Crisman

Description: modified (diff)

But it works on XP as well.

comment:9 in reply to:  8 Changed 11 years ago by Karl-Dieter Crisman

Replying to kcrisman:

But it works on XP as well.

By which I meant Win 7 as well.

comment:10 Changed 11 years ago by Karl-Dieter Crisman

User "RegB" was able to use this successfully for this - see this sage-windows thread.

So this just needs someone to look at the actual spkg.

comment:11 Changed 11 years ago by Karl-Dieter Crisman

Reviewers: Reg Burgess

That is, this needs someone other than me to look at the actual spkg and its construction :) - should be very easy.

comment:12 in reply to:  10 Changed 11 years ago by Karl-Dieter Crisman

Replying to kcrisman:

User "RegB" was able to use this successfully for this - see this sage-windows thread.

That was on Vista, just FYI. Maybe we need another XP reviewer for this?

comment:13 Changed 11 years ago by Karl-Dieter Crisman

Description: modified (diff)

comment:14 Changed 11 years ago by Dima Pasechnik

somehow I don't need this spkg for Win 7 - what comes with Sage 4.7.2 installs OK.

comment:15 in reply to:  14 Changed 11 years ago by Karl-Dieter Crisman

Replying to dimpase:

Welcome back!

somehow I don't need this spkg for Win 7 - what comes with Sage 4.7.2 installs OK.

Yes, this was only ever an XP problem, as far as I know.

If you can verify this spkg doesn't cause problems on Win 7, then I think that would be enough to positively review and merge. You are right that XP is less and less important in the long run, of course.

comment:16 Changed 11 years ago by Jason Grout

Is this superseded by the Twisted 11.0 spkg at #11847?

comment:17 in reply to:  16 Changed 11 years ago by Karl-Dieter Crisman

Report Upstream: N/ANone of the above - read trac for reasoning.

Is this superseded by the Twisted 11.0 spkg at #11847?

Almost certainly not - the devels on the link above seemed not to care too much - the last change was 18 months ago, and they didn't want to do anything without a Cygwin slave. I can try to see whether the new package applies sometime tonight, but I doubt that it's in upstream. And of course this was only ever on XP.

Still, if you can apply this without too much trouble on yours, with a patch applied only in case of Cygwin, I think that would be a good idea.

comment:18 Changed 11 years ago by Karl-Dieter Crisman

You mean #11874, of course!

Changed 11 years ago by Karl-Dieter Crisman

Attachment: trac_11497.diff added

For reference only

comment:19 Changed 11 years ago by Karl-Dieter Crisman

Authors: Karl-Dieter Crisman, Mike Hansen
Milestone: sage-4.8sage-duplicate/invalid/wontfix
Reviewers: Reg BurgessReg Burgess, Karl-Dieter Crisman, Dmitrii Pasechnik
Status: needs_reviewpositive_review

After testing on the newest Cygwin on XP, I think this issue may have been an older Cygwin issue, not an XP issue per se. I have no problems building the current p2, the p3 on this ticket, or Twisted 11 on #11874. Setting to sage-invalid, keeping Reg as a reviewer for checking this worked on Vista and Dima for checking on Win 7 this wasn't necessary.


I've added trac_11497.diff for reference in case we need to apply this in the future for some reason.

comment:20 Changed 11 years ago by Jeroen Demeyer

Resolution: worksforme
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.