Opened 8 years ago

Closed 4 years ago

#11439 closed defect (worksforme)

optional package mpi4py-1.1.0.spkg does not build on sage-4.7.1.alpha1

Reported by: mariah Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: sd32, sd40.5
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The optional package mpi4py-1.1.0.spkg does not build on skynet/eno (x86_64-Linux-core2-fc) on sage-4.7.1.alpha1:

...
/usr/local/gcc-4.6.0/x86_64-Linux-core2-fc/bin/gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/home/mariah/sage/sage-4.7.1.alpha1-x86_64-Linux-core2-fc/local/include/python2.6 -c src/MPI.c -o build/temp.linux-x86_64-2.6/src/MPI.o
In file included from src/MPI.c:3:0:
src/mpi4py.MPI.c:135:17: fatal error: mpi.h: No such file or directory
compilation terminated.
error: command '/usr/local/gcc-4.6.0/x86_64-Linux-core2-fc/bin/gcc' failed with exit status 1

real    0m0.392s
user    0m0.141s
sys     0m0.097s
sage: An error occurred while installing mpi4py-1.1.0

Change History (11)

comment:1 Changed 8 years ago by was

  • Keywords sd32 added

comment:2 Changed 8 years ago by swenson

Does eno have an MPI package installed, like mpich?

comment:3 Changed 7 years ago by vbraun

  • Keywords sd40.5 added

The mpi4py spkg relies on

  • either the optional openmpi spkg, or
  • a standard mpi compiler wrapper (like mpic++) in the path

If neither is installed, the installation of mpi4py fails. The error message should be amended to point the user to the openmpi spkg, or explain how to use the MPICXX etc. environment variables.

comment:4 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 4 years ago by jdemeyer

Not a bug since the dependency was missing.

comment:9 Changed 4 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

comment:10 Changed 4 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:11 Changed 4 years ago by vbraun

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.