Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#11427 closed defect (duplicate)

optional spkg database_gap-4.4.12.p0.spkg fails test on sage-4.7.1.alpha1

Reported by: Mariah Lennox Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: sd32
Cc: Mike Hansen, Nicolas M. Thiéry Merged in:
Authors: Reviewers: William Stein
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

The optional spkg database_gap-4.4.12.p0.spkg installed in sage-4.7.1.alpha1 causes the following test to fail:

eno% ./sage -t -long -force_lib "devel/sage/sage/groups/perm_gps/permgroup.py"
sage -t -long -force_lib "devel/sage/sage/groups/perm_gps/permgroup.py"
**********************************************************************
File "/home/mariah/sage/sage-4.7.1.alpha1-x86_64-Linux-core2-fc/devel/sage/sage/groups/perm_gps/permgroup.py", line 2350:
    sage: G.isomorphism_to(H)
Expected:
    Permutation group morphism:
      From: Permutation Group with generators [(2,3), (1,2,3)]
      To:   Permutation Group with generators [(1,2,4), (1,4)]
      Defn: [(2,3), (1,2,3)] -> [(2,4), (1,2,4)]
Got:
    Permutation group morphism:
      From: Permutation Group with generators [(2,3), (1,2,3)]
      To:   Permutation Group with generators [(1,2,4), (1,4)]
      Defn: [(2,3), (1,2,3)] -> [(2,4), (1,4,2)]
**********************************************************************

See #11582 for partially disabling this doctest.

Change History (9)

comment:1 Changed 11 years ago by François Bissey

Do you mean installing the spkg leads to the failure? We have observed that exact same test failure since #10334 was introduced for the first time in the 4.7 release cycle in sage-on-gentoo https://github.com/cschwan/sage-on-gentoo/issues/50

As far as we can see gap just seem to be very fussy in its behavior.

comment:2 Changed 11 years ago by François Bissey

Cc: Mike Hansen Nicolas M. Thiéry added
Status: newneeds_info

After examination of that spkg I think that's definitely the cause of the problem in sage-on-gentoo. The content of this spkg is in the default gap tarball but sage stripe it to save space, it seems that the rest is put in this spkg. In gentoo we install gap in full.

It could be interesting to find out exactly which dataset cause the failure and why. But if the test is that sensitive it should be changed. I'll copy Mike Hansen and Nicolas Thiéry who did most of the work on #10334.

comment:3 Changed 11 years ago by Jeroen Demeyer

On the buildbot machine RHEL 5.5-64 bin (rosemary) the following error is observed:

sage -t -long  -force_lib devel/sage/sage/groups/perm_gps/permgroup.py
**********************************************************************
File "/home/buildbot/build/sage/rosemary-1/rosemary_binary/build/sage-4.7.1.rc0/devel/sage-main/sage/groups/perm_gps/permgroup.py", line 2350:
    sage: G.isomorphism_to(H)
Expected:
    Permutation group morphism:
      From: Permutation Group with generators [(2,3), (1,2,3)]
      To:   Permutation Group with generators [(1,2,4), (1,4)]
      Defn: [(2,3), (1,2,3)] -> [(2,4), (1,2,4)]
Got:
    Permutation group morphism:
      From: Permutation Group with generators [(2,3), (1,2,3)]
      To:   Permutation Group with generators [(1,2,4), (1,4)]
      Defn: [(2,3), (1,2,3)] -> [(1,2), (1,2,4)]
**********************************************************************

comment:4 Changed 11 years ago by Jeroen Demeyer

Description: modified (diff)
Milestone: sage-4.7.1sage-4.7.2

See #11582 for partially disabling this doctest.

comment:5 Changed 11 years ago by William Stein

I also tested that with the optional spkg installed the doctest now works.

wstein@sage:/scratch/wstein/sd32/sage-4.7.2.alpha2$ ./sage -t -long -force_lib "devel/sage/sage/groups/perm_gps/permgroup.py"
sage -t -long -force_lib "devel/sage/sage/groups/perm_gps/permgroup.py"
         [15.0 s]
 
----------------------------------------------------------------------
All tests passed!
Total time for all tests: 15.1 seconds

comment:6 Changed 11 years ago by William Stein

Resolution: fixed
Status: needs_infoclosed

comment:7 Changed 11 years ago by William Stein

Keywords: sd32 added

comment:8 Changed 11 years ago by Leif Leonhardy

Milestone: sage-4.7.2sage-duplicate/invalid/wontfix
Resolution: fixedduplicate

comment:9 Changed 11 years ago by Leif Leonhardy

Reviewers: William Stein
Note: See TracTickets for help on using tickets.