Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11405 closed defect (duplicate)

magma interface needs work in presence of newlines

Reported by: was Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers: William Stein
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

We have

sage: magma.eval("a:=2;\nb:=3;\nprint a,b;")
'b:=3;\nprint a,b;'

instead of the expected

sage: magma.eval("a:=2;\nb:=3;\nprint a,b;")
'2 3'

Where the latter is to be expected since

Magma V2.17-4     Mon May 30 2011 12:54:51 on deep     [Seed = 2436835871]
Type ? for help.  Type <Ctrl>-D to quit.
> a :=2;
> b :=3;
> print a,b;
2 3

Nils Bruin originally reported this on sage-devel.

Change History (4)

comment:1 Changed 10 years ago by kedlaya

Is this a duplicate of #11401?

comment:2 Changed 10 years ago by was

  • Resolution set to duplicate
  • Status changed from new to closed

Yep, dup of #11401.

comment:3 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix

comment:4 Changed 10 years ago by leif

  • Reviewers set to William Stein
Note: See TracTickets for help on using tickets.