Opened 14 years ago

Closed 13 years ago

#1132 closed defect (wontfix)

error inverting matrix over RQDF

Reported by: mhansen Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I've attached b.sobj which you can load to reproduce the error.

sage: ~b
---------------------------------------------------------------------------
<type 'exceptions.ZeroDivisionError'>     Traceback (most recent call last)

/home/mike/<ipython console> in <module>()

/home/mike/matrix0.pyx in sage.matrix.matrix0.Matrix.__invert__()

<type 'exceptions.ZeroDivisionError'>: self is not invertible
sage: c = b.change_ring(RDF)
sage: ~c

[ 0.0277777777778  0.0277777777778  0.0277777777778  0.0277777777778  0.0277777777778  0.0277777777778]
[  0.111111111111  -0.111111111111  0.0555555555556 -0.0555555555556  0.0555555555556 -0.0555555555556]
[             0.0              0.0  0.0962250448649  0.0962250448649 -0.0962250448649 -0.0962250448649]
[            -0.0             -0.0  0.0962250448649 -0.0962250448649 -0.0962250448649  0.0962250448649]
[  0.111111111111   0.111111111111 -0.0555555555556 -0.0555555555556 -0.0555555555556 -0.0555555555556]
[ 0.0277777777778 -0.0277777777778 -0.0277777777778  0.0277777777778 -0.0277777777778  0.0277777777778]

Attachments (1)

b.sobj (472 bytes) - added by mhansen 14 years ago.

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by mhansen

comment:1 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.10 to sage-2.9.1

comment:2 Changed 13 years ago by mhansen

This is due to the following:

sage: b = load('/home/mike/Desktop/b.sobj')
sage: A = b.augment(b.parent().identity_matrix())
sage: B = A.echelon_form()
sage: B[5,5]
1.000000000000000000000000000000000000000000000000000000000000000
sage: B[5,5] == 1
False

comment:3 Changed 13 years ago by mabshoff

This ought to be solved. Maybe it is fodder fir Bug Day 8.

Cheers,

Michael

comment:4 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.2.1 to sage-duplicate/invalid/wontfix
  • Resolution set to wontfix
  • Status changed from new to closed

Wontfix since we will remove RQDF - see #3762.

Cheers,

Michael

Note: See TracTickets for help on using tickets.