Opened 10 years ago

Closed 6 years ago

#11281 closed defect (fixed)

.. math:: environment ignored in the live documentation

Reported by: nthiery Owned by: jason, mpatel, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: days30
Cc: sage-combinat Merged in:
Authors: Reviewers: John Palmieri, Keshav Kini, Karl-Dieter Crisman
Report Upstream: Reported upstream. Developers acknowledge bug. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by kcrisman)

.. math:: environments seem to be ignored in the live documentation. See e.g. the second method random_element in http://localhost:8080/doc/live/reference/quat_algebras/sage/algebras/quatalg/quaternion_algebra.html (with the notebook running on your machine).

The inline math environments work fine. The same .. math environment work fine in the static documentation

Change History (17)

comment:1 follow-up: Changed 10 years ago by jhpalmieri

Hmm. This works for me (both 4.6 and 4.7.rc1, OS X 10.6.7 Intel, both Safari and Firefox). Can you give more information about your set-up? Has it worked for you with any version of Sage? Are you sure it wasn't still "Processing Math"?

comment:2 in reply to: ↑ 1 Changed 10 years ago by nthiery

  • Description modified (diff)

Replying to jhpalmieri:

Thanks for your quick answer!

Hmm. This works for me (both 4.6 and 4.7.rc1, OS X 10.6.7 Intel, both Safari and Firefox). Can you give more information about your set-up?

Oups, I was not specific about where in the file the issue wasx. I just added info to the description.

Sage 4.6.2 vanilla, Firefox 3.6.16, Ubuntu and OpenSuse?.

Has it worked for you with any version of Sage?

Sorry, I don't know.

Are you sure it wasn't still "Processing Math"?

Nope.

Cheers,

comment:3 Changed 10 years ago by jhpalmieri

Just to clarify, both of the ".. math" environments in this file (in random_element and theta_series) work for me.

comment:4 Changed 8 years ago by kini

  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:5 Changed 8 years ago by kini

  • Reviewers set to Keshav Kini
  • Status changed from needs_review to positive_review

comment:6 Changed 8 years ago by kcrisman

  • Report Upstream changed from N/A to Reported upstream. Developers acknowledge bug.
  • Status changed from positive_review to needs_info

I have changed this to "reported upstream, developers acknowledge bug" (see #8482 for rationale).

comment:7 Changed 8 years ago by kini

Yup, OK.

comment:8 Changed 8 years ago by kini

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-5.9

comment:9 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:10 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:11 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:12 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:13 Changed 6 years ago by kcrisman

  • Description modified (diff)

comment:14 Changed 6 years ago by kcrisman

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers changed from Keshav Kini to John Palmieri, Keshav Kini, Karl-Dieter Crisman
  • Status changed from needs_info to positive_review

I cannot reproduce this either, see comment:3, on Safari or FF. Mathjax seems to be fine. I've closed the upstream ticket, please open a different upstream ticket if you still find this a problem. (There are a number of changes that might have made this happen, including upgrading sagenb.org.)

comment:15 Changed 6 years ago by nthiery

Seems indeed to work fine on my machine. Kuddos to whoever fixed this :-)

comment:16 Changed 6 years ago by kcrisman

It will forever remain a mystery!

comment:17 Changed 6 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.