Opened 9 years ago

Closed 9 years ago

#11272 closed defect (fixed)

cube(center, size=0.5) does not return a cube centered at center

Reported by: slabbe Owned by: jason, was
Priority: major Milestone: sage-4.7.1
Component: graphics Keywords: cube
Cc: Merged in: sage-4.7.1.alpha1
Authors: Sébastien Labbé Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by slabbe)

The center of the cube is affected by the argument size :

sage: c = cube(center=(10,10,10), size=0.5)              
sage: c.bounding_box()                            
((4.75, 4.75, 4.75), (5.25, 5.25, 5.25))          

The intended behavior is that the center is independant of the size:

sage: c = cube((10,10,10), size=0.5)              
sage: c.bounding_box()  
((9.75, 9.75, 9.75), (10.25, 10.25, 10.25))  

For the patchbot : Apply trac_11272-doctest.patch

Attachments (2)

trac_11272_cube_centre.patch (1012 bytes) - added by johanbosman 9 years ago.
trac_11272-doctest.patch (719 bytes) - added by slabbe 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by johanbosman

comment:1 Changed 9 years ago by johanbosman

  • Status changed from new to needs_review

comment:2 Changed 9 years ago by slabbe

  • Authors set to Johan Bosman
  • Reviewers set to Sébastien Labbé
  • Status changed from needs_review to positive_review

Problem is fixed. All test passed in the directory sage/plot/plot3d. Documentation builds fine. Positive review. Thanks for the fix!

Sébastien

comment:3 Changed 9 years ago by jdemeyer

  • Status changed from positive_review to needs_work

Needs to be rebased to sage-4.7.rc1

comment:4 Changed 9 years ago by johanbosman

It seems to work properly in sage-4.7.rc1 without patches. Apparently the bug has already been fixed in another ticket.

comment:5 Changed 9 years ago by jdemeyer

  • Authors Johan Bosman deleted
  • Milestone changed from sage-4.7.1 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers changed from Sébastien Labbé to Sébastien Labbé, Johan Bosman
  • Status changed from needs_work to closed

Duplicate of #10796.

comment:6 follow-up: Changed 9 years ago by slabbe

I wonder if the doctest could be added to Sage anyway. Can we reopen the ticket for it?

Sébastien

comment:7 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-4.7.1
  • Resolution duplicate deleted
  • Status changed from closed to new

comment:8 in reply to: ↑ 6 Changed 9 years ago by jdemeyer

Replying to slabbe:

I wonder if the doctest could be added to Sage anyway.

Good idea!

Changed 9 years ago by slabbe

comment:9 Changed 9 years ago by slabbe

  • Description modified (diff)
  • Status changed from new to needs_review

comment:10 Changed 9 years ago by jdemeyer

  • Authors set to Sébastien Labbé
  • Merged in set to sage-4.7.1.alpha1
  • Resolution set to fixed
  • Reviewers changed from Sébastien Labbé, Johan Bosman to Jeroen Demeyer
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.