Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11242 closed defect (duplicate)

python spkg build fails on Ubuntu 11.04

Reported by: pipedream Owned by: GeorgSWeber
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: python crypt natty
Cc: Merged in:
Authors: Reviewers: Jan Groenewald, Leif Leonhardy
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I found this build failure with sage 4.6.2 on Ubuntu 11.04 64bit beta2. I believe it affects all sage versions, all arches, on Ubuntu 11.04 and higher.

http://groups.google.com/group/sage-devel/browse_thread/thread/593b9a4124f5075d

Report upstream: Ubuntu already patch their python as I propose to patch the sage python with one line to build the crypt module with -lcrypt. Upstream python does not build on Ubuntu without this patch, and this one line suffices. Upstream python says this is because Ubuntu 11.04 introduced some multiarch support. More details in the google thread and the python bug referred to in that thread.

Files changed in the attached spkg: patches/Setup.dist patches/Setup.dist.patch spkg-install SPKG.txt changelog

This needs testing on other releases, distros, and OSes. If it breaks building on other systems a specific check for Ubuntu can be added with [ "xlsb_release -d" == "xDescription: Ubuntu 11.04" (after 1 May 2011 when this release is out). Then the patch can only be applied for that specific version of Ubuntu.

This spkg can be tested with sage -f python-2.6.4.p10.spkg. Revert with cd SAGE_ROOT/spkg/standard; sage -f python-2.6.4.p9.spkg.

The error is obvious -- both in the python install log and when starting sage import crypt fails.

Change History (7)

comment:1 Changed 10 years ago by pipedream

How do I delete this ticket? IT is a duplicate of 11243

comment:2 Changed 10 years ago by leif

  • Component changed from build to packages
  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is a duplicate of #11447, #11243, fixed in the Python 2.6.4.p11 spkg.

comment:3 Changed 10 years ago by leif

  • Status changed from needs_review to positive_review

comment:4 Changed 10 years ago by leif

  • Merged in set to sage-4.7.1.rc0
  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:5 Changed 10 years ago by leif

  • Authors Jan Groenewald deleted
  • Reviewers set to Jan Groenewald, Leif Leonhardy

comment:6 Changed 10 years ago by jdemeyer

leif, please explain the "merged in: sage-4.7.1.rc0"

If this ticket is duplicate, there is nothing to merge...

comment:7 Changed 10 years ago by jdemeyer

  • Merged in sage-4.7.1.rc0 deleted
Note: See TracTickets for help on using tickets.